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Theory and Decisions

FTDesign allows professional looking documents to be formatted and designed in a GUI 
interface much like those which are found in many of today's word processing software 
packages. Use color, frames, images, barcodes and many other graphic elements to create a 
good looking document.

Substitute your own company address and demographics, either based on the input data or 
from simple text files so you won't need to change forms if you change your address or add a 
new division. Make objects print conditionally - based on test on the input data or 
comparisons on input data. Use masking to present data as you'd like to with address or other 
details strung together in sentences with superfluous spaces removed, or as words replacing 
amounts or as special masking with constants surrounding your data. The next few pages will 
show you how to do this and more with FormTrap.

Design Process
FormTrap applications, while simple and easy to use, are advanced and therefore you will 
need to spend time learning the theory and concepts.

The design process typically involves the following steps:

• Create a new project and then add a new form to the project.

• Design your form layout, creating objects and defining page elements.

• Capture representative print line data from your host application. Ensure one 
multi-page document is included (for records mode forms, see below).
• Use the FormTrap Repaginator to simplify your Print Line mode data to sim-

plify the forms design.
• Map the Print Line data directly to your forms.

• For Records Mode data, save the output file from your application, making sure 
at least one document will extend more than one page.

CHAPTER 1 
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• Enter the field names for your records according to the specifications (you 
may ignore unused records, these will be ignored).

• Link the field names to your printed variables.

• Test the form using the Preview Function in color or B&W.

• Build the project to generate the load (.asc) file.

• Design and add the rest of your forms to the project.

• When test results are satisfactory, build the project to generate the load (.asc) 
file.

• Update the load (.asc) file to the production environment.

Planning Form Design
Before you put together a form design, there are several issues you need to consider. All 
involve defining your needs in conjunction with studying the application that generates the 
information to go onto the forms.

The key to effective form design is to identify what information you need in the form, where to 
get it and when to print it.

Here are some questions you should consider to before you start the form design.

• Whether to use Print Line mode or Records mode?

• What output language to use (PCL or PCLXL (PCL6) or PostScript)?

• What design elements you will need?

Print Line or Records Mode

When planning the design of your new form, you have the option of either extracting 
information from existing print lines (with the Repaginator available to simplify your data) or 
writing a program to deliver records mode output.

Print Line mode caters for existing applications and requires minimal change. Here are some 
questions you should consider to determine whether or not you can produce an output from 
an existing print program. Please do a Repagination of the data, and see if you can answer 
these questions:

• Can you easily segregate the first and subsequent page headers for a document 
using a "change" in the document ID or page number - for page number, can 
you easily determine Page 1 (from Page 10, 11 and so on)?

• Can you recognize the document footer (totals)?

• Can you identify and remove "end of page", "continued" and "brought forward" 
lines?

• Are you able to eliminate redundant lines? If so, then just select non-blank lines 
to finish.

• Are there different types of detail lines? Do they have distinguishing features or 
literals or the absence of data that can be used for tests to select the types your 
require?
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Print Line mode excels when working with consistent documents. If your application output 
is generally consistent, or can be made consistent with the Repaginator, designing forms with 
Print Line mode is suggested.

Records mode is ideal for new applications and where your new requirements cannot be 
supported from the existing print lines. In this mode, the data required is written as records, 
with the first character of each record identifying the page element.

The different design concepts used in Print Line mode and Records mode will be explained in 
the Printline (page 19) or Records Mode section (page 31). 

PCL or PostScript Output

FormTrap supports the output file formats PCL (PCL5e and PCL5c), PCLXL (PCL6) and 
PostScript (Level 2). The mode of output is selected when you build your project, not at run 
time. Outputs appear identical, but there may be small differences in font handling. PCLXL 
(PCL6) output may be transferred to ANY Windows printer if that option has been purchased 
for your production system.

In some cases you may need to build the same project for different printers, for example for 
older PCL only printers and color PDF delivery.

When do I choose PCL?

PCL is faster and the output is smaller. You would choose the PCL option:

• For printing forms across networks, particularly networks with low bandwidth 
or high traffic or;

• For printing checks (cheques). FormTrap supports the MICR font only in PCL 
mode. (This will be extended to PCLXL (PCL6) if there is sufficient customer 
interest.)

When do I choose PCLXL (PCL6)?

PCLXL (PCL6) while smaller than PostScript is still at least 2 times larger than PCL. It is a 
more modern language than PCL and is therefore available as the sole PCL choice in some 
printers (Xerox and Lexmark printers for example). Select PCLXL (PCL6) when:

• Using printers that no longer support PCL but support PCLXL (PCL6).

• When you wish to use the "Print to ANY Windows Printer" option.

When do I choose PostScript?

PostScript files are typically 3 times larger than the PCL equivalent. You would choose the 

PostScript option:

• If you want to produce color PDF files for email delivery or;

• If you plan to outsource your printing. PostScript files are more readily sup-
ported than PCL by third party printing houses.

Note: If your printer is a less known model, PostScript is the least likely to have 
glitches or differences from the standard, which we have seen with PCL from 
time to time.
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Form Design

Here are some questions you should consider to before you start the form design.

Static or Dynamic Form?

The terms static or dynamic are used to describe the handling of the Detail Area in a form 
design. In a Static form, the Detail Area is a fixed area on the page. In a Dynamic form, the 
size of the Detail Area will shrink and grow to accommodate different document headers and 
footers.

A Static form is the simplest design method. Use this approach for short documents that 
rarely go over one page. The static form "wastes" the space of the footer on all pages except the 
last but is by far the simplest to design.

A Dynamic form is more flexible but also more complex to design. You would use a Dynamic 
form to allow more space for details on long documents or when documents require "C/Fwd 
with subtotals" on intermediate pages. Dynamic forms are good with repaginated data or with 
Records Mode files. 

For Static forms, without a repagination step, you must accommodate the number of detail 
lines that are printed on any one page. If all the detail lines do not fit into the detail area, 
FormTrap will produce an overflow page, with the same Base page information and the 
remaining detail lines. For Dynamic forms (including Records Mode), FormTrap calculates 
the "fit" and paginates when necessary.

Do I need a Detail Area?

It is not always necessary to have a Detail Area. Forms for a single transaction (like a car hire) 
or that are largely details about an individual (like a loan transaction) may not need a detail 
area.

Forms dealing with multiple products or multiple transactions require a detail area. A typical 
example is an invoice, where the detail area details multiple products.

In either mode, it is common to define only those lines that you require. FormTrap ignores 
undefined lines.

How do I identify Data Items?

While you can easily identify various items of information on an existing printed page, some 
fields may be uncommon and may only print when some special event occurs. Similarly, some 
fields may have special conditions that are not obvious.

Once you have identified all of the data fields, it is a good idea to list them and allocate a name 
to them. At this time you should also note the maximum number of characters in each field 
and any special characteristics.

Here is an example of some data fields we have extracted from an invoice and the field names 
we have assigned them:

Data Field Record Field Name

invoice number inv no

invoice date inv date

customer name cust name
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For more information on Defining Fields in Print Line Mode see page 23.

For more information on Defining Fields in Records Mode see page 31.

How many different Detail Lines do I need?

This is again a decision you need to make to produce the clearest and most legible form 
possible. Good practice is to have a detail line on the form for each different type of detail line 
in the data. Note that a consistent block of data over more than one line should defined as a 
single "detail line". Highlight important information by using different font styles and sizes.

In Print Line mode, define only those detail lines that you require and remove irrelevant and 
unwanted lines with the Repaginator.

When do I use Headers and Footers?

Use these features when designing a Dynamic form. Headers and footers allow you to define a 
different amount of space at the top and bottom of given pages in a document, such as having 
a large space for the headers of the first page and a smaller space for the headers of the 
remaining pages. The same is true of footers, which allow you to define a larger space on the 
final page to cater for trailer details such as totals.

These options are useful when you don't need detailed information in the headers and footers 
on every page of a document, such as delivery address details, which would only be necessary 
on the opening page.

When do I use Group Headers?

Group headers appear in the Detail Area and can be considered as the table headers of a 
typical document. There are two types of group header, implicit, which is defined by the 
subsequent detail line, and explicit, which is defined by the input data.

When headers appear in the detail section of your input data, you should use an explicit 
header in your form design. This type of header works in the same way as a normal detail line 

(and repeats on subsequent pages if defined that way) and is generated when found in the 
input data.

When headers do not appear in the input data, you can use the successful creation of a detail 
line to imply the preceding header. In this case, when a certain type of detail line is created in 
the output, FormTrap will generate an implicit header object before printing that detail line. 
This is common with Repaginated data.

customer number cust no

customer address line 1 cust add1

customer address line 2 cust add2

item description item desc

quantity ordered qty ord

total amount total amt

Data Field Record Field Name
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Tools and Options

When you launch FTDesign, you are presented with a blank workspace. The workspace is the 
area in which all your form design takes place. This includes placing all your graphic and text 
objects, variable and constant. FTDesign is a windows environment, so everything appears in 
your workspace exactly as it does on the final output.

The blue cross-hatched area around the edges of your workspace represents the unprintable 
area of the page and can be customized as part of the Base page preferences.

Design Window
Standard toolbar contains the options common in most Windows programs such as file 
saving, printing and opening. 

Drawing toolbar contains the tools used to create the objects that make up the framework 
of your form design including text, lines, boxes, ellipses, images and barcodes.

Properties toolbar contains the tools used to modify the properties of the objects that 
make up the framework of your form design including text, lines, boxes, ellipses, images and 
barcodes.

CHAPTER 2 
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Tools toolbar contains icons for all of the special formatting tools used to make the form 
design process easy, fast and accurate.

Using the Zoom Tools

The Zoom tools control the size of the page in the FTDesign workspace. You can enlarge the 
page to work closely on one area of the form, or reduce the zoom to appreciate the entire 
design.

Tool  Action

The Zoom tools are used to control the size of the page.

To access the Zoom tools click the Zoom button on the 
Tools toolbar. When the Zoom button is toggled the 
Zoom tools will appear on a separate toolbar in the 
FTDesign toolbar area.

Drag Zoom - zoom to a selected area. Click the Drag 
zoom tool and hold the left mouse button down while 
drawing a box around the area you wish to zoom to.

Zoom by Value - zoom to a selected ratio. Click the 
Zoom by value tool, and from the list of options that 
appears, select the required zoom percentage.

Drawing Toolbar
Standard Toolbar

Tools Toolbar
Properties Toolbar
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The amount of magnification can also be set using the Zoom... option from the View menu.

Using the Grid Tools

The grid tool is available to facilitate arranging and moving objects.

A visible grid with a snap to grid functionality is available as a guide for laying out objects 
during form design. You can view the grid when designing but it is not printed. When you turn 
on Snap to grid, objects are automatically aligned with intersections of the grid, making it 
easier to lay out objects with uniform spacing.

To configure grid settings:

• Select Grid... from the Tools menu.

• Modify the values to change the distance between horizontal and vertical grid 
intersections.

• Click the OK button to accept the changes

Page Width - zoom to fit page width in the screen. Click 
the Zoom to page width tool.

Page Height - zoom to fit page height in the screen. 
Click the Zoom to page height tool.

Tool  Action
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When Snap to grid is turned on, objects are automatically aligned with intersections of the 
grid. Turn on Snap to grid by clicking the button on the Tools toolbar, or by selecting Snap 
to grid in the Tools menu. 

Design Options
Before you start designing forms you can customize your design environment to suit your own 
preferences. To view the current design environment settings, select Options from the Tools 
menu.

Preferences

On the Preference tab, you can set the following options:

• Measurement units - allows you to select the unit of measurement used for all 
design functions. Options include millimetres, centimetres, inches, points, picas 
and 300dpi.

• Paste at - allows you to select where an object pasted from the clipboard will be 
inserted.

• Printer driver warning - a warning is given when an incompatible printer is 
selected.

• Reload project - FTDesign automatically reloads the last project on start up.

• Double click on structure map pane acts as 'Go' - when selected, double-click-
ing on a page element in the structure map pane will place that page element in 
focus in the design window.

• Language - Changes the language used in FTDesign, FTSplitDef and the 
Repaginator. These applications must be restarted in order for this change to 
take effect. FTDesign, FTSplitDef and the Repaginator will now be displayed in 
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the selected language, including menus, dialog boxes, field names and page ele-
ment names.

Folders

On the Folders tab, you can set the following options.

• Forms and Project definitions directory - default directory when opening and 
saving a new form. Select Use last selected folder to set the default form and 
project directory to the last folder selected when opening or saving a form or 
project.

• Pictures, logos directory - default directory when inserting a picture or a logo 
on the form. Select Use last selected folder to set the default picture directory to 
the last folder selected when inserting a picture.

• Built projects directory - default directory for output built project (.asc) files.
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• Substitution files directory- default directory for test substitutions files.

Data Map

On the Data map tab, you can set the following options:

•  Revert to 'Select' mode after mapping - after a data field is mapped, the cursor 
will return to select mode.

• Apply underlying text after move/resize - when a test field is moved to another 
data field, the rule will change so it reflects the new data.
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• Colors - select your own colors for print mapping in Print Line mode.

PCL Bins

Available custom PCL bins store the required attributes to force the printer to select other 
than the normal bin for input and output. Input is for paper selection, output for is 
destination. This section assumes you will give preference to one of PCL (PCL52 or PCL5c) or 
PCLXL (PCL6) for your bin selections for custom bins as they may be different. PostScript 
bins cannot be permanently labeled in this fashion as they are provided by the printer driver.

On the PCL Bins tab, you can set the following options:

• Name - the name of the custom printer bin to be displayed in FTDesign. Cus-
tom PCL Bins are used to define extra printer input and output bins when the 
printer driver does not make them visible.

• Bin type - set whether the custom bin is an input tray or output bin.

• PCL Escape - set the numeric part of the PCL escape code for selecting the cus-
tom bin. This value can be found in your printer manual.
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You can edit the preferences of any custom PCL bin at anytime by simply left-clicking the 
appropriate bin in the Available custom PCL bins box and changing the settings. PCL 
bins are only available when a PCL printer driver has been selected.

Project Defaults

Project defaults are used to initialize newly created projects and when the stand-alone form is 
viewed using the preview options.

On the Project defaults tab, you can set the following Font usage and MICR options:

• All  - FormTrap uses a combination of True Type fonts and printer-resident fonts 
when designing and building your form. Once All  is selected you can then set 
the following options:
• Prefer True Type Fonts - defaults to True Type fonts on all new projects. 

FormTrap uses True Type fonts instead of printer-resident fonts when both 
are present i.e. font 'Arial' exists both as a printer-resident and system based 
True Type font). Prefer True Type Fonts is the default option. Uncheck this 
box to default to printer-resident fonts on all new projects.

• Always build fonts - when FormTrap cannot find either the True Type or 
printer-resident fonts it will substitute the next best fit for the missing font. 
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Check this box to ignore font related errors or when the exact appearance of 
text glyphs is irrelevant.

• Printer - FormTrap uses only printer-resident fonts when designing and build-
ing your form. Printer-resident fonts are installed on the printer. Once Printer is 
selected, you can then set the following option:
• Post Script Level 1 - produces Postscript Level 1 output files. This option is 

generally used for specific faxing solutions that require Postscript Level 1 
input.

• System - FormTrap uses only True Type fonts when designing and building 
your form. True Type fonts are installed in your Windows font directory.

• Add Unicode subranges - this allows you to include additional ranges of char-
acter glyphs into your load (.asc) file. Subranges are supplied by TCG during 
the installation and on request. To add a new Unicode subrange:
• Click the Add button. The Unicode subranges dialog box will open.
• Select from the list of available subranges and click the OK button. 
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• MICR - Select a default MICR file for all new projects. The MICR box refers to 
the location of the MICR font file you are using to generate the MICR line on 
check forms. The MICR font is only available when using a PCL printer driver 
to design and build forms.
• Click the browse "..." button and locate the MICR directory.
• Select the correct MICR file and click the OK button.
• If you are not producing checks (cheques) or you are not using the PCL 

printer driver you can ignore this option.

FTPreview

On the FTPreview tab, you can set the following options:

• Try to match using form title - FTPreview will try to find a data file which 
matches the title of the form. For example, if the form is named invoice.frm, 
FTPreview will look for a data file called invoice.txt or invoice.dat in the speci-
fied Input data files folder.

• Default data file - click the browse "..." button to select a default sample data 
file. If a data file has not been loaded FTPreview will use the specified data file 
as the default.
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• Launch maximized - the FTPreview window will open maximized.

Custom Mask

On the Custom mask tab, you can set the following options:

• New - create a new custom amount mask. This is useful if you regularly use a 
currency format that is not available in the default list. The new mask will then 
be available in the list of mask types.

• Edit - edit the format of an existing custom mask.
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Delete - delete an existing custom mask.

For more information on Creating Custom Masks see page 133.

Postscript Resident Fonts

On the PostScript Resident Fonts tab, you can add additional fonts which can be used 
when designing a form.

The following options are available:

• New - Use the New... button to add a font to the available font list.
• You will need to determine the name the printer uses for the font you wish to 

add. You can find the font name by printing a list of the printer resident Post-
Script fonts from the production printer.

• Enter the Family name for the font and the Style suffixes for Regular, Bold, 
Italic  and Bold Italic.

• Click the OK button.

• Edit - edit the information for an already available PostScript font. Select the 
appropriate font and click the Edit button.
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• Delete - delete a PostScript font from the list of available FTDesign fonts. 
Select the appropriate font and click the Delete button.
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Print Line or Records Mode

FormTrap has two fundamental modes of operation.

• Print Line mode - converts existing print applications, especially legacy sys-
tems.

• Records more - Used for new applications (or planned major changes to an 
existing application).

In the absence of other considerations, Records mode provides better control and is faster to 
put into production. However, it does require creation of a program to extract the required 
data ready for printing.

Print Line mode requires no changes to the existing system. It is therefore ideal when used 
with either legacy systems or systems where the report designs come standard with the 
application software. With the facilities provided by the Repaginator, this mode is close to 
Records mode in flexibility and performance.

For more information on the Repaginator see page 154.

Print Line Mode
The data sent to FormTrap in Print Line mode is unchanged from the original application. 
Unlike Records mode, the purpose of Print Line mode is to extract data from a print stream as 
it is generated by the application. FormTrap achieves this by mapping areas of the print 
stream data for print line extraction. Most print streams with more than one simple detail line 
should have been run through the Repaginator first, to remove redundant lines and to move 
total lines behind the Header (they can then be treated as part of the header). These steps 
simplify Print Line form design as well as allowing use of some of the advanced features.

CHAPTER 3 
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Print line extraction is the process of identifying fields in the print line data and linking them 
to the field names allocated to variable text objects on the form. Data is identified according to 
its position on a page in the print stream and linked to the form by highlighting areas of 
sample text. This is called print mapping. 

Input Data

Before you begin designing a Print Line form, you will need a sample data file from your 
application to use for mapping fields and testing your form. For best results, you should select 
a data file that includes the maximum amount of data that may appear on any given page and 
contains at least one multiple page document as it is the variation across input pages that 
allows you to define when to print sub-forms, group headers and different types of detail 
lines. Check that you have all of the variation in detail lines included in your sample file(s).

FTDesign will load any Unicode text file to use for print mapping. Non-Unicode files 
(normally ASCII) will convert to Unicode as they are loaded into FTDesign.

Loading a Sample Input File

Data files are processed by FormTrap through the Repaginator, if repagination has been 
specified for the file. The Repaginator step eases Form Design by removing lines that are not 
required.

To load a sample data file:

• Select Load data file... from the Tools menu.

• In the Open dialog box, select the data file to use as a sample.

• In the Ascii/Unicode conversion frame select the appropriate conversion 
options:         
• Auto - FTDesign will automatically convert the selected sample data file to 

Unicode based on your current system locale.
• Custom - choose a custom filter to convert the data file. Click the Filters... 

button and the Input Filters dialog box will open. Click Add and select a filter 
to be used for conversion.
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• None - no conversion filter is used.

• Click the Open button to load the sample data file.

• The sample data file appears in the printmap window.

• Double click on the printmap work space to display the properties of the data 
file.
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• Page height - the number of rows per page. This defaults to 80 on the 
assumption that most samples will have each page terminated by a Form 
Feed before 80 rows per page.

• Infinite  - this should be ticked for repaginated files.
• Column - starting column of the Detail Area in the printmap workspace.
• Row - starting row of the Detail Area in the printmap work space.
• Width - width of the Detail Area in the printmap workspace.
• Height - height of the Detail Area in the printmap workspace.

Moving through the Sample Data File

These four icons move through the Data file, moving to the First, Previous, Next and Last page 
respectively. For files other than those with the Infinite attribute, press the Next page icon to 
check the Page height is correct.

Incorrect page height may occur on files from Unix systems that do not have Form Feeds. 
Change Page Height to 60 and check again. Adjust Page Height up and down until each 
page appears at the same level within the printmap work space.

Repagination

The FormTrap Repaginator is a tool used to restructure Print Line mode data files before they 
are processed by the FormTrap Print Logic and merged with your form. The Repaginator 
modifies pagination within your data files, reduces each document to one long page and 
moves data elements header, footer and details into set positions. Repaginator allows deletion 
of subsequent page headers and removal of unwanted lines from the input, thus reducing 
complexity in form design.

Launching the Repaginator

To launch the Repaginator from within FTDesign:

• Select Printline repaginator... from the Tools menu or click the Repaginator 

 tool button in the top left hand corner of your printmap work area.
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• The FormTrap Repaginator will be launched in a separate window, displaying 
the sample data file you loaded in FTDesign. You can now create your Repagi-
nation rules.

The Repaginator file (.rpg) is included in your load (.asc) file when you build your project. 
FormTrap checks for the Repaginator file in your load (.asc) file and, if present, repaginates 
the data file prior to processing the data with your form.

Configure Repaginator file

A repagination file may be used with multiple forms and this provides a way to link in an 
existing Repagination file (for example Invoices and Credit Notes may share their format and 
require just the one repagination file).

To set the FormTrap Repaginator file for your project:

• Select Repagination... from the Define menu.

• The Repagination dialog box opens.

• In the Repaginator rule file text box enter the full path and name of your 
Repaginator file or click the Browse... button to locate the Repaginator file and 
click the Open button. Repagination files are normally stored in the same folder 
as the forms they link to.

• Click the OK button. When you build your project, the repaginator file you have 
selected will be included in your load (.asc) file.

Defining Fields

Before starting to design the layout of a Print Line mode form, you can define the fields that 
belong to each element of the form. Each field can also be defined as the variable text or 
barcode object is created.

After creating the fields, you need to map the fields to the corresponding areas in the loaded 
sample data.

Create Record Fields

To define the record fields on each page element:

• Select the appropriate element on the Go menu.

• Select Properties of... from the Define menu.
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• On the Records tab, click on the New... button to add a new record field.

• Type in a field name, unique if the Base Page is being processed, otherwise 
unique to detail lines or sub-forms.

• Click the OK button (and press OK again to enter another new field).

• Repeat the above steps to add other record fields

Delete Record Fields

To delete an existing field

• Select the appropriate element on the Go menu.

• Select Properties of... from the Define menu.
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• On the Records tab, click and select the field you wish to delete.

• Click on the Delete button to delete the field.

Mapping Fields

Map using create extract button

This form of mapping is used when a field may exist but is not represented in this particular 
data file, Drag and Drop is preferable. Note that the position including length of the field is 
shown progressively in the bottom bar of the Data File Windows.

To map fields using the create extract field button:

Click the Create extract button  on the toolbar. The cursor will change to an I-bar , 
or stop sign  if no field is yet selected. For stop sign, select a data field name from the field 
list (left of the printmap work area) to change to an I-bar.

• Holding down the left mouse button, highlight the characters representing the  
field in your sample data file, displayed in the printmap window.
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• Release the mouse button to open the Create Extraction Field dialog box.

• Select the corresponding field from the Available fields list.

• Click OK to map.

• The mapped characters will be highlighted green and the field will be linked 
and highlighted on the field list.

Map using drag and drop

To fields using the drag and drop method:

• Click to select the field you wish to map from the Structure Map Pane.
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• Holding the left mouse button down, drag the field and drop it on top of the 
characters representing the field in your sample data file, displayed in the print-
map window.

• Left click on the field and drag to resize, or double click and change the Col-
umn, Row or Width values in the Extract dialog box.

• The mapped characters will be highlighted green and the field will be linked 
and highlighted in the field list.

• Repeat the above steps for all remaining fields on your page. 
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Establishing Comparison Rules

Data files may contain different detail lines and sub-forms. The method used to distinguish 
between different lines (to select and print the correct format) is to use comparison rules to 
allow FormTrap to identify what it is looking at.

Each rule is a simple test. The following rules are available:

Setting Detail Line Rules

When a form has more than one detail line a comparison rule is used to establish which detail 
line is printed. Each rule is a simple test that must be satisfied for the detail line to print. 
Where a detail line has multiple rules, all of the rules must be satisfied to qualify. "Detail line" 
may be multiple lines from the file in some instances, where the set is represented in the same 
format. (Note: Test fields should be created last for each deatil line).

To create a test field on a detail line:

• Ensure that the appropriate detail line is selected on the Go menu.

• Select Properties of... on the Define menu.

• On the Records tab, click the New... button to add a new field.

Rule Description

No Rule Default setting

Blank Field must be blank

Not Blank Field must contain data

Equal to Field must equal the supplied characters

Not equal to Field must not equal the supplied characters

Greater than Field must be greater than the supplied characters

Greater than or 
equal to 

Field must be greater than or equal to the supplied char-
acters.

Less than Field must be less than the supplied characters.

Less than or 
equal to 

Field must be less than or equal to the supplied charac-
ters.
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• Enter an appropriate name into the Name text box.

• Click the OK button to create the field and then OK again to accept the changes.

• In the Structure Map Pane select the appropriate detail line.

• Find something that is unique to the detail line. In this example we will use the 
word "Tax".

• Click the Create extract button  on the toolbar. The cursor will change to an 

I-bar .
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• Press and hold the left mouse button to highlight the characters representing the 
test data in your sample data file, displayed in the Printmap window. Allow for 
the full size of the field, not just what is visible on this page.

• Release the mouse button to open the Create Extraction Field dialog box.

• Select the corresponding test field name from the Available Fields list.

• Select a comparison rule from the Comparison rule drop down menu. In this 
example we use the Equal to comparison rule and enter the comparison string 
"Tax" in the Compare with text box. The rule is case sensitive.

• The mapped Characters will be highlighted yellow to indicate a test field.

Defining Rule Evaluation Order

Evaluation order is the sequence in which FormTrap tests the comparison rules on the detail 
lines. Set the evaluation order of detail lines so there is no ambiguity in the evaluation, with 
the most specific rules evaluated first.

To change the order of evaluation for the detail lines:

• Right click on the detail line in the Structure Map Pane.
• From the drop down menu select Evaluation order.
• Move the detail line up or down using the options on the menu.

• Highest - top of the evaluation order.
• Higher - up one in the evaluation order.
• Lower - down one in the evaluation order.
• Lowest - bottom of the evaluation order.
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Records Mode
In Records mode, the data sent to FormTrap is specially formatted. The first column of each 
line identifies the page element and indicates to FormTrap which part of the form it should 
print. The rest of the line is comprised of fields that have a fixed start position and a fixed 
length. The figure below shows a sample records mode data file.

Input Data

Records mode does not require a sample data file loaded before designing the form. However 
to preview the form and make sure that all required fields are included a sample data file must 
be used. For best results, you should generate a file that overflows to two pages.

You may ignore records in the sample data that are not required on the form by simply not 
defining them as detail lines or sub-forms.

Defining Fields

In Records mode the unique page element identifier, as the first character of that row, 
indicates what fields follow. The name, start position and length defines each field. While 
unusual, each field can also be defined as needed, as the variable text or barcode object is 
created.

Create fields

To define the fields on each page element:

• Select the appropriate page element on the Go menu.

• Select Properties of... from the Define menu.



32

• On the Records tab, click on the New... button to add a new field.

• Type in the field name, start position and length. Note, you may sub-define a 
field, in which case the longer field is sorted ahead of its sub-definition fields.

• Click the OK button.

• Repeat the above steps to add other fields to the page element.

Delete fields

To delete a field:

• Select the appropriate page element on the Go menu.

• Select Properties of... from the Define menu.

• On the Records tab, click and select the field you wish to delete.

• Click on the Delete button to delete the field.
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Shift fields within a record

To shift the starting position of fields within a record:

• Select the appropriate page element on the Go menu.

• Select Properties of... from the Define menu.

• On the Records tab, click and select the field you wish to shift.

• Click on the Shift button.

• In the Shift fields dialog box, enter a positive number to increase the starting 
position and a negative value to decrease the starting position.
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• The starting position of the selected field and all subsequent fields will shift 
accordingly.

Identifiers in Design

In Records mode, the first column of each line is a page element identification and will 
indicate to FormTrap which part of the form it should print. The rest of the line is comprised 
of fields that have a fixed start position and a fixed length. The figure below shows a sample 
records mode data file.

Records starting with 0 contain data for the Base page. Almost all form designs include 
Record 0. Data on the Base page is document based (e.g. invoice number, customer and 
address) and consistent on each page. When FormTrap sees a 0 identifier in the first column 
it starts a new document. Good practice is to place a literal identifying the document content 
as the first field (i.e. 0Invoice...).

Lines starting with uppercase A through Z identify detail lines. When FormTrap sees an 
A-Z identifier in the first Column it will print the corresponding detail line.
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Lines starting with lowercase a through j identify explicit group headers. When 
FormTrap sees an a-j identifier in the first column it will print the corresponding group 
header.

Lines starting with 1 through 9 identify sub-forms. When FormTrap sees a 1-9 identifier in 
the first column it will print the corresponding sub-form. Sub-forms are used to print 
conditional information that may occur only once in the data.

Predefined Fields
FormTrap offers a number of pre-defined fields to cover common data requirements. These 
include the previous, current and next page numbers for the current document, the current 
system date, and the current number of pages in the entire print job.

These fields are calculated by FormTrap at runtime.

Use pre-defined field

To use a pre-defined field:

• Choose Text from the Draw menu or click the Text tool button on the toolbar.

• Click and drag diagonally to add the new text frame.

• Release the mouse button and the Text dialog box will open.

• On the Definition tab, enter sample text into the text box. When creating varia-
ble text objects it is best to make the sample text the maximum possible length 
of the field extracted from the data.

Field Description

Page No Current page in the document

Next Page No Next page in the document

Previous Page No Previous page in the document

Doc Page count Total number of pages within the document

Job Page No Current page in the print job

Date printed Date the document is printed
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• To link all the sample text to the field, click on the Link all... button.

• To link a section of the sample text to the field, highlight the relevant text and 
click the Link selection... button.

• In the Link to field dialog box, select the pre-defined field name from the Field 
drop down menu - pre-defined fields are last in this list.
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      For more info on Masks see Masking and Font Change on page 124.

• Click the OK button to link the field to the pre-defined field.
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Design and Objects

This section introduces the design concepts important to creating your form, both 
individually in detail and collectively as part of the full design process. Basic and advanced 
design concepts are covered.

This section describes the concepts of form design that are shared by both Records and Print 
Line modes of FormTrap input. Differences between the two design modes are explained in 
detail in Printline or Records Mode in the previous chapter.

Designing a Static Form
A static form design has the Detail Area in a fixed area on the page. This approach is typically 
used to handle Print Line mode data, where the input has a constant number of detail lines on 
each page of the input file. Static form are ideal where most of the documents are one page 
only.

A static form uses the basic features of FormTrap and reflects the designs of previous 
versions. The Base page contains the framework for the form and most fixed objects appear 
on the Base page. Details print within a defined area that is fixed on every page. Forms 
designed with versions prior to 6.0 and opened with FTDesign are "static" by default.

A static form is characterized by:

• Header on Base page - the heading information is displayed on each page of the 
document. The heading area remains the same size on each page.

• Static Detail Area - the area holding detail lines (Detail area) is in the same 
position and the same size on each page.

• Table object on Base page - the column headings and frame for the detail area 
(collectively Table object) is defined on the Base page.

• Report footer on Sub-form - the total information and intermediate page "con-
tinued" messages are on different sub-forms with the total at the end of the doc-
ument.

CHAPTER 4 
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Designing a Dynamic Form
In a dynamic form, the Detail Area shrinks and grows to accommodate different sized 
document headers and footers. This approach is better suited to handling Records mode data 
and especially repaginated Print Line mode data.

A Dynamic form is more flexible but also more complex to design. Use a Dynamic form for 
long documents where you require more details per page and/or "C/Fwd" amounts on 
intermediate pages. In this mode, Page headers may have less detail on pages after the first 
page of a document, and more space is left on the final page to carry trailer details.

The design process for creating a dynamic form harnesses many of the advanced features of 
FormTrap. A dynamic form is one on which the framework is not fixed, but will print in 
different positions according to the size of headers and footers. Little is defined on the Base 
page and the area in which details print will also be defined dynamically page to page as the 
form is printed.

A dynamic form is characterized by:

• Dynamic header - using the Report and Page headers you can structure a 
dynamic heading area which can be used to conserve space on a form.

• Floating Detail Area - the Detail Area moves up or down to accommodate the 
headers and footers.

• Table object created as needed - the table object surrounding the Detail Area is 
created with its assigned group header.

• Dynamic footer - using the Report and Page footers you can structure a dynamic 
footer area which can be used to conserve space on a form.

• C/Fwd is defined as part of the Page Footer and with a B/Fwd within the Detail 
area on the following page.

Creating Objects
When you design FormTrap forms with FTDesign, you create objects and arrange them on a 
page. Objects are the building blocks of a form and may include text, barcodes, lines, boxes, 
ellipses and pictures. You can format these objects to suit your needs and arrange them with 
the tools in FTDesign.

Objects can be of two types:
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• Constant objects represent a value that is the same each time the form is 
printed. Constant objects may be a company logo or a return address that is the 
same on each page of your form. Lines and rectangles are also considered con-
stant objects.

• Variable objects obtain their values from the print stream. These are the place 
holders for fields in the data you want to print on the form. Variable objects also 
control the appearance of the data by formatting it with font styles or even dis-
playing data as a barcode.

Objects may be direct or retrieved through Substitution files. Substitution files replace the 
form object with information from a file - meaning the information is easily and permanently 
changed without modification to the form. Substitutions may be fixed (for example, company 
name, address and phone number copied from files rather than built into the form) or 
variable (same information for different companies where the file name includes variable 
data).

Creating Line Objects

There are three tools used for creating horizontal, vertical, and diagonal lines.

 Horizontal Line tool

 Vertical Line tool

 Line tool used to draw a diagonal line

To create a line object:

• Choose Line from the Draw menu or click the Line tool button on the toolbar. 
The cursor changes to a cross-hair pointer.

• Click and hold down the left mouse button on the page where you want to start 
the line. Drag the mouse to draw the line.

• Release the mouse button where you want to end the line.

• Hold the CTRL key down whilst using the mouse to move the endpoint of the 
diagonal line. This will round the angle of the line to an increment of 15 
degrees.

• To resize the line, click on one of the black handles and drag in or out to make 
the line longer or shorter.

To change the properties of a selected line:

• Double click on the line or select the line and then click on the Object proper-
ties button on the toolbar.

• On the Format tab, edit:
• Pattern - solid, dotted or dashed line.
• Color - change the color of the line.
• Width - make the line thin or thick.
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• End cap - modify the end of the line to a rounded or square end.

• On the Position tab, edit the line's position.

The Print rules tab allows conditions to be set for printing of this object, see Print Rule for an 
object on page 74.

Creating Rectangle and Square Objects

 The Rectangle tool is used to create a rectangle or a square.

To create a rectangle:
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• Choose Rectangle from the Draw menu or click the Rectangle button on the 
toolbar. The cursor changes to a cross-hair pointer.

• Click and drag the mouse diagonally to define the size of the rectangle.

• Release the mouse button.

• To resize the rectangle, click on one of the black handles and drag in or out to 
make the rectangle bigger or smaller.

To create a square:

• Choose Rectangle from the Draw menu or click the Rectangle button on the 
toolbar. The cursor changes to a cross-hair pointer.

• Click and drag the mouse diagonally across while holding the CTRL key down.

• Release the mouse button.

• To resize the square, click on one of the black handles and drag in or out while 
holding the CTRL key, to make the square bigger or smaller.

To create a rectangle from its centre point:

• Choose Rectangle from the Draw menu or click the Rectangle button on the 
toolbar. The cursor changes to a cross-hair pointer.

• Click and drag the mouse diagonally across while holding the SHIFT  key 
down.

• Release the mouse button.

• To resize the rectangle, click on one of the black handles and drag in or out 
while holding the SHIFT  key, to make the rectangle bigger or smaller.

To change the properties of a selected rectangle:

• Double click on the rectangle or select the rectangle and then click on the 
Object properties button on the toolbar.

• On the Format tab, edit:

• Line attributes - transparency, pattern, color and width.

• Fill  attributes - transparency, pattern and color.
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• Rounded corners - give the rectangle rounded corners.

• On the Position tab, edit the rectangle's position and size.

The Print rules tab allows conditions to be set for printing of this object, see Print Rule for an 
object on page 74.

Creating Ellipse and Circle Objects

 The Ellipse tool is used to draw an ellipse or a circle.
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To draw an ellipse:

• Choose Ellipse from the Draw menu or click the Ellipse tool button on the tool-
bar. The cursor changes to a cross-hair pointer.

• Click and drag the mouse diagonally to define the size of the ellipse.

• Release the mouse button.

• To resize the ellipse, click on one of the black handles and drag in or out to 
make the ellipse bigger or smaller.

To draw a circle:

• Choose Ellipse from the Draw menu or click the Ellipse tool button on the tool-
bar. The cursor changes to a cross-hair pointer.

• Click and drag the mouse diagonally across while holding the CTRL key down.

• Release the mouse button.

• To resize the circle, click on one of the black handles and drag in or out while 
holding the CTRL key, to make the circle bigger or smaller.

To draw a ellipse from its centre point:

• Choose Ellipse from the Draw menu or click the Ellipse tool button on the tool-
bar. The cursor changes to a cross-hair pointer.

• Click and drag the mouse diagonally across while holding the SHIFT  key 
down.

• Release the mouse button.

• To resize the ellipse, click on one of the black handles and drag in or out while 
holding the SHIFT  key, to make the ellipse bigger or smaller.

To change the properties of a selected ellipse:

• Double click on the ellipse or select the ellipse and then click on the Object 
properties button on the toolbar.

• On the Format tab, edit:
• Line attributes - transparency, pattern, color and width.
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• Fill  attributes - transparency, pattern and color.

• On the Position tab, edit the ellipse's position and size.

The Print rules tab allows conditions to be set for printing of this object, see Print Rule for an 
object on page 74.
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Image Objects
 The Picture tool is used to insert an image. 

Creating Image Objects

Graphics such as logos and scanned signatures can be inserted easily into the form design. 
FTDesign supports bitmap (.bmp), JPEG (.jpg), GIF and TIFF graphics. To include graphics 
in other file formats, you need to convert them using one of the many freely available graphics 
format converters.

To insert an image:

• Choose Picture from the Draw menu or click the Picture tool button on the 
toolbar. The cursor changes to a cross-hair pointer.

• Click and drag the mouse diagonally to locate the top-left corner of the picture. 
The picture draws at it’s native size.

• Release the mouse button and the Picture dialog box will open.

• On the Settings tab, edit
• By clicking the browse "..." button you may choose a different picture file.
• Linked - these pictures are not copied into the form, but referenced by the 

form from a folder when FTDesign is used. The production system MUST 
have access to pictures that are linked. To link the picture, tick the Linked 
checkbox.

• Scalable - these pictures can be resized by moving the black handles when 
the picture is selected. Holding the SHIFT  key down while resizing will 
retain the proportions of the image. To make the image scalable tick the Scal-
able checkbox.

Note: Image scaling is the most process intensive function in FormTrap, for 
production efficiency build logos and images to their final size using your 
graphics tools rather than scaling in FormTrap.

• Print white color transparent - Checking this box will make all the white 
pixels within a picture transparent. The transparent pixels do not print at run 
time. This option is especially useful when placing a picture on top of a 
filled/colored background. To make the white pixels within an image trans-
parent check the Print white color transparent check box.

Image Substitution

FormTrap allows you to change the text and graphics that are printed on the form without 
amending the form itself. FormTrap's special Substitution facility permits you to insert 
information from external files onto the output form. Using Substitution, the one FormTrap 
Load File (.asc) can be used for a number of different organizations - with their specific logo 
and address information contained in external files and inserted during a print run. This is 
convenient for:

• Customizing Forms without Rebuilding - where a common form needs differ-
ent graphics or text, the graphic/text can be replaced without re-designing forms 
or even requiring FTDesign.
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• Code Interpretation - where a form requires a particular text or graphic to 
appear based on a code from your incoming data, the value of the data is used to 
access the graphic or text to be placed on the form.

• Personalization and/or Additional Information (constant field) - where a form 
includes a personalization or other information not supplied from the incoming 
file data. Company name, logo, address, PO Box, phone and fax number etc. are 
best represented this way and can be shown in various fonts/sizes and locations 
on many forms, with just the one location to instantly change the details.

For more information on Barcode Substitution see page 70.

For more information on Text Substitution see page 58.

The substitution file is the external file that is opened by FormTrap at run time. Any 
information in the file will be inserted onto the form using the formatting and alignment 
applied to the substitution object.

For more information on Substitution Location see page 11.

Constant Image Substitution

To insert a constant substitution image object:

• Double click on the image object created.

• On the Settings tab, enter the name of the substitution file into the text box.
• Select Substitute Using Constant File Name from the Image substitution 

dropdown menu.
• Enter the full name of the image e.g. image.jpg, you wish to substitute into 

the File text box.
• Check the Fit to frame check box to force the image to resize to fit the allo-

cated image box on the form.

Note: This is inefficient, for commonly used graphics, please scale and save a 
right-sized image in the substitution file.

• Check the Keep aspect ratio box to maintain the proportions of the inserted 
image.
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•  Use the Horizontal alignment and Vertical alignment to align the inserted 
image within the allocated image box.

• Click the OK button.

• Resize the grey substitution image box to fit the allocated space on the form.

• In the example below FormTrap will open image.jpg and insert the image from 
the file onto the form using the formatting and alignment applied to the substi-
tution image object.

For more information on Substitution Location see page 11.

Variable Image Substitution

To insert a variable substitution image object:

• Double click on the image object created.
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• On the Settings tab, select Substitute Using Variable File Name from the 
Image substitution dropdown menu.

• Click the Build file name... button to create the variable file name.

• On the Name Builder tab enter the sample text into the File Name text box. 
When creating substitution text objects it is best to make the sample text the 
maximum possible length of the field extracted from the substitution file.
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• To link all the sample text to the variable, click on the Link all... button. To link 
a section of the sample text to the variable, highlight the relevant text and click 
the Link selection... button.

• In the Link to field dialog box, select the predefined field name from the Field 
drop down menu.
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• Click OK to link the record variable to the substitution object.

• Check the Trim leading and trailing spaces from variable data to remove lead-
ing or trailing spaces from the file name.

• Click the OK button.

• In the example below FormTrap will open logo001.jpg and insert the image 
from the file onto the form using the alignment applied to the substitution image 
object.

For more information on Substitution Location see page 11.
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Text Objects
 The Text tool is used to insert a constant or variable text object. 

Creating Text Objects

To insert a text object:

• Choose Text from the Draw menu or click the Text tool button on the toolbar. 
The cursor changes to a cross-hair pointer.

• Click and drag the mouse diagonally to add the text frame.

• Release the mouse button and the Text dialog box will open.

• On the Definition tab, enter the desired text into the text area to create a con-
stant text object. Click the Link selection or Link all  button to define a variable 
text object. This object will "import" data from a field in the data file.

• On the Format tab, set the attributes of the constant text object:
• Alignment - alignment of text within the text frame. Using decimal align-

ment as an example, which is often applied on numeric text objects,
• Select the Decimal option for the Horizontal Alignment of the two text 

object to be aligned.

• Select the Right alignment tool  on the alignment toolbar.
• Click on the "." (dot) of the first object.
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• The second object decimal aligns itself to the "." (dot) of the first 
object.

• Line spacing - for multi-line text objects, select a fixed spacing or enter a 
custom line spacing. To enter a custom line spacing, select Exact from the 
Type menu and then enter a value in the Exact text box.

• Word wrap - for a multi-line text object, check the Word wrap box to wrap 
lines automatically, varying the height of the text object according to the 
amount of text entered. The text may grow down, up or both ways depending 
on the Vertical alignment being Top, Bottom or Center.

Note: The position at which the text word-wraps is defined by the size of the text 
frame which you can reset by moving the handles.

• Remove empty variable lines - remove blank lines from the variable data. 
For example, if a set address lines is missing line 2, the blank line is sup-
pressed at runtime.
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• On the Position tab, set the position of the constant text object. Enter a value in 
Left, for the object's offset from left value and Top, for the object's offset from 
top value.

• On the Font tab, set the attributes of the font used for the constant text object:
• Name - select the font type.
• Style - font can be Regular, Bold, Italic or Bold Italic.
• Size - select the size of the font.
• Underline - check the Underline box for the text to be underlined.
• Orientation - orientation of the text relative to the page.
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• Color - select the color of the text.

The Print rules tab allows conditions to be set for printing of this object, see Print Rule for an 
object on page 74.

Linking to a Field

To link a text object to a field:

• Double click on the text object created.

• On the Definition tab, edit the sample text in the text box. The sample text 
should be the same length and similar data to the incoming field (for example, 
enter dates as valid and in the same format as the incoming data).
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• To link the entire field, click on the Link all  button.

• To link a section of the sample text to the field, highlight the relevant text and 
click the Link selection button.
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• Using the Link selection button you can have a number of fields within the one 
text object.

• In the Link to field dialog box, select the field name from the Field drop down 
menu.
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• Check the Substitute from file check box to insert information from external 
files onto the output form.

• From the Mask as drop down menu select a mask to format the variable.

• If the variable is not available, click on the new "..." button to add a new varia-
ble.

For more information on Defining Fields in Print Line Mode see page 23.

For more information on Defining Fields in Records Mode see page 31.

Text Substitution

FormTrap allows you to change the text and graphics that are printed on the form without 
amending the form itself. FormTrap's special Substitution facility permits you to insert 
information from external files onto the output form. Using Substitution, the one FormTrap 
Load File (.asc) can be used for a number of different organizations - with their specific logo 
and address information contained in external files and inserted during a print run. This is 
convenient for:

• Customizing Forms without Rebuilding - where a common form needs differ-
ent graphics or text, the graphic/text can be replaced without re-designing forms 
or even requiring FTDesign.

• Code Interpretation - where a form requires a particular text or graphic to 
appear based on a code from your incoming data, the value of the data is used to 
access the graphic or text to be placed on the form. This can be used to translate 
terms in one language to another - for example units of measure.

• Personalization and/or Additional Information (constant field) - where a form 
includes a personalization or other information not supplied from the incoming 
file data. Company name, logo, address, PO Box, phone and fax numbers etc. 
are best represented this way and can be shown in various fonts/sizes and loca-
tions on many forms, with just the one location to instantly change the details.

For more information on Image Substitution see page 46.

For more information on Barcode Substitution see page 70.

The substitution file is the external file that is opened by FormTrap at run time. Any 
information in the file will be inserted onto the form using the formatting and alignment 
applied to the substitution object.

For more information on Substitution Location see page 11.

Constant Text Substitution

To insert a constant substitution text object:

• Double click on the text object created.
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• On the Definition tab, enter the name of the substitution file into the text box.

• Click the Link all... button to link the sample text to the substitution file.

• In the Link to field dialog box:
• Check the Substitute from file check box.
• Select Constant from the Field drop down menu.
• Leave the remainder blank and select None for Mask as.
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• Click the OK button.

• In the example below FormTrap will open add.txt and insert information from 
the file onto the form using the formatting and alignment applied to the substi-
tution text object.

For more information on Substitution Location see page 11.

Variable Text Substitution

To insert a variable substitution text object:

• Double click on the text object created.



61

• On the Definition tab, enter sample text into the text box. When creating substi-
tution text objects it is best to make the sample text the maximum possible 
length of the field extracted from the substitution file.

• Click the Link all... button to link the sample text to the record variable.

• In the Link to field dialog box:
• Check the Substitute from file check box.
• Select the appropriate variable from the Field drop down menu.
• Enter the prefix of the variable substitution files into Prefix e.g. add-.
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• Enter the extension of the variable substitution files into Suffix e.g. .txt 
(including the dot).

• Click the OK button.

• In the example below FormTrap will open add-001.txt and insert information 
from the file onto the form using the formatting and alignment applied to the 
substitution text object.

Note: Regarding the File Name: The linked "field" portion of the file name is 
automatically left and right stripped of spaces

Field content (>field<) File Name Accessed

>  001  < add-001.txt

>  001< add-001.txt

>001  < add-001.txt
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For more information on Substitution Location see page 11.

Symbol Characters

To add a symbol character in FTDesign:

Copy Symbol in Character Map

• Open Windows Character Map. Select Start Menu > Run > and type "charmap".
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• Click OK.

• In Character Map mark the required symbol and press Select, then Copy.

Insert Symbol in FTDesign

• Create a new text object.

• Paste (CTRL + V) the symbol in the definition tab.



65

• On the Font tab, select the same font as was used in Character Map.

• Click OK.

Note: The character may not appear correctly in the definition tab, nor on the form 
design, but it will print correctly.

Barcode Objects
 The Barcode tool is used to insert a constant or variable barcode object.

Creating Barcode Objects

To insert a barcode object in FTDesign:

• Choose Barcode from the Insert menu or click the Barcode tool button on the 
toolbar. The cursor changes to a cross-hair pointer.

• Click and drag the mouse diagonally to add the barcode frame.

• Release the mouse button and the Barcode dialog box will open.

• On the Definition tab
• Symbology - select the appropriate barcode encoding method from the Sym-

bology menu.
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• Text - enter the desired barcode value into the Text box. Click the Link selec-
tion or Link all button to define a variable text object.

• On the Format tab, set the attributes of the constant barcode object:
• Text location - the value of the barcode can be hidden, or appear above or 

below the barcode.
• Rotated - check the Rotated box for the barcode to be rotated 90 degrees.
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• On the Position tab, set the position of the constant barcode object. Enter a 
value in Left, for the object's offset from left value and Top, for the object's off-
set from top value.

• On the Font tab, set the attributes of the font used for the constant barcode 
object:
• Name - select the font type.
• Style - font can be Regular, Bold, Italic or Bold Italic.
• Size - select the size of the font.
• Underline - check the Underline box for the text to be underlined.
• Orientation - orientation of the text relative to the page.
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• Color - select the color of the text.

The Print rules tab allows conditions to be set for printing of this object, see Print Rule for an 
object on page 74.

To change the size of the selected barcode object:

• Select the handles and drag to size. The width of the barcode “jumps” from size 
to size as additional increments are added to all bars and spaces. The height 
handles move smoothly as the height is increased or reduced.

Linking to a Field

To link a barcode object to a field:

• Double click on the barcode object created.

• On the Definition tab, edit the sample barcode digits in the text box. It is best to 
make the sample barcode digits the same length as the field extracted from the 
input file.
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• To link all the sample barcode to the field, click on the Link all  button.

• To link a section of the sample barcode to the field, highlight the relevant char-
acters and click the Link selection button.
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• In the Link to field dialog box, select the field name from the Field drop down 
menu.

• If the field is not available, click on the new "..." button to add a new field.

For more information on Defining Fields in Print Line Mode see page 23.

For more information on Defining Fields in Records Mode see page 31.

Barcode Substitution

Barcode substitutions are almost never used, however are possible using the same 
instructions as text objects.

For more information on Image Substitution see page 46.

For more information on Text Substitution see page 58.

The substitution file is the external file that is opened by FormTrap at run time. Any 
information in the file will be inserted onto the form using the formatting and alignment 
applied to the substitution object.

For more information on Substitution Location page 11.

Constant Barcode Substitution

To insert a constant substitution barcode object:

• Double click on the barcode object created.
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• On the Definition tab, enter the name of the substitution file into the text box.

• Click the Link all... button to link the sample barcode digits to the substitution 
file.

• In the Link to field dialog box:
• Check the Substitute from file check box.
• Select Constant from the Field drop down menu.
• Leave the remainder blank and select None for Mask as.
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• Click the OK button.

• In the example below FormTrap will open 9999.txt and insert information from 
the file onto the form using the formatting and alignment applied to the substi-
tution barcode object.

      For more information on Substitution Location see page 11.

Variable Barcode Substitution

To insert a variable substitution barcode object:

• Double click on the barcode object created.

• On the Definition tab, enter sample barcode digits into the text box. It is best to 
make the sample barcode digits the same length as the field extracted from the 
substitution file.
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• Click the Link all... button to link the sample barcode digits to the record varia-
ble.

• In the Link to field dialog box:
• Check the Substitute from file check box.
• Select the appropriate variable from the Field drop down menu.
• Enter the prefix of the variable substitution files into Prefix e.g. barcode-.
• Enter the extension of the variable substitution files into Suffix e.g. .txt 

(including the dot).

• Click the OK button.

• In the example below FormTrap will open barcode-987654321.txt and insert 
information from the file onto the form using the formatting and alignment 
applied to the substitution barcode object.

Note: Regarding the File Name: The linked "field" portion of the file name is 
automatically left and right stripped of spaces

Field content (>field<) File Name Accessed

>  987654321  < barcode-987654321.txt

>  987654321< barcode-987654321.txt

>987654321  < barcode-987654321.txt

For more information on Substitution Location page 11.
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Print Rules

Set Print Rules for an Object

This tab allows you to set conditions, which must be true, otherwise the object is ignored for 
printing. Text objects ignored may include Substitutions and/or Associated File Objects, as 
well as normal text.

To change print rules for an object:

• On the Print rules tab, edit:
• Add to add a new print rule.
• Select What to compare from the  list drop-down. The drop-down has the 

full field list applicable to the form component which holds this object (ie 
Base Page, Detail Line etc.).



75

• Select How to compare, there are a number of options available.

Number: and Text: versions of Is equal to and Is not equal to compare differently.

Number: Is equal to compares these equally:

            Text: Is equal to does not compare them equally

• Compare to offers Field - select another field to compare from the drop 
down, and Constant - key a constant.

0 

  0

0.00

-0.00
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In this example "Invoice" will print when the value of the field "Total Due" is greater then 
-0.01. (i.e. 0.00 or greater)

In this example "Credit Note" will print when the value of the field "Total Due" is less 
then 0.00.

The finished expression is shown in the window, with any additional expressions forming a 
list. You may Edit and Remove a selected expression, or Remove all to delete the entire 
contents.

Expressions must all be true to print the object.

Deleting Objects
To delete an object:

• Select the object you wish to delete.

• Right click on the selected object and choose Delete from the menu, or press the 
Delete button on the keyboard.

To delete a number of objects on the same page element:

• Select the objects you wish to delete by holding down the SHIFT key.

• Right click on the selected objects and choose Delete from the menu, or press 
the Delete button on the keyboard.



77

Arranging Objects
Once you have created objects on your form, you can change your form design efficiently 
using object arrangement tools. FormTrap offers features which are used specifically for 
laying out the form.

Duplicating Objects

Duplicate command will create a copy of an object, offset from the original.

• Select the object to be duplicated.

• Select Duplicate from the Edit menu, or use the keyboard short cut CTRL+D.

Grouping Objects

By grouping objects together, you can control them as a single entity - useful when you need 
to move or align or duplicate several objects at once.

To group objects:

• Select the objects that you wish to group by holding down the SHIFT  key and 
clicking each object or by drawing a marquee around them.

• Select Group from the Edit menu or click the Group tool button  on the 
toolbar.

• One set of black handles appears around the group.

To separate the group of objects:

• Click on the group to select it.

• Select Ungroup from the Edit menu or click the Ungroup tool button  on 
the toolbar.

Changing Object Order

When you create a new object, FTDesign places it on top (in front) of objects already on the 
page. Object order allows you to control how objects overlap on the same page by putting 
them in front of, or behind other objects.

There are four options available when modifying object's order:
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• Bring to front  - object brought to the top most layer

• Front one  - object brought forward one layer

• Back one  - object sent back one layer

• Send to bottom  - object sent to the bottom most layer

To modify the object's order:

• Select the object you wish to move.

• From the Edit menu, select Order and then choose the appropriate option.

• Alternatively, right click on the selected object and choose the appropriate 
option from the Order menu.

Multiple Objetc Sizing

Resizing objects to a uniform size is quickly achieved with FTDesign's size function.

There are four options available when resizing objects:

• To widest - resize all objects to the same width as the widest object.

• To narrowest - resize all objects to the same width as the narrowest object.
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• To tallest - resize all objects to the same height as the tallest object.

• To shortest - resize all objects to the same height as the shortest object.

Following is one example of adjusting the smaller rectangle to the same size as the bigger one.

Select the objects to be sized by clicking on each of them while holding the SHIFT key, or by 
drawing  a marquee around the objects. Two or more objects must be selected.

• Choose Size from the Edit menu, and then select To widest option.

• Choose Size from the Edit menu, and then select To tallest option.

Multiple Object Properties

 Tool for Color

 Font up one point size, Font down one point size

 Bold (or not bold), Italic (or not italic), Underlined (or not 
underlined)

 Font and Point size



80

Multiple Object Properties

Changing the properties of individual objects can be time consuming, particularly if you have 
a large number of objects that you need to make the same change to on your form. FTDesign 
allows you to change the font and color properties of multiple objects using the toolbar.

To change the properties of multiple objects simultaneously:

• Select the objects you wish to modify by holding down the SHIFT  key and 
clicking each object or by drawing a marquee around them.

• Use the Properties toolbar to modify the properties of the selected objects:
• If you have selected text and barcode objects you can change the Font, Font 

Size, Font style or Color using the tools on the Properties toolbar.
• If you have selected other objects such as lines, boxes and ellipses you can 

change the color using the Color tool on the Properties toolbar.

See Replacing Fonts on page 139 for global font changes.

Using the Nudge Tool

 The Nudge tool defines horizontal and vertical increments to move selected object(s) 
actioned by the arrow keys on your keyboard.

There are three methods of defining the nudge increment in FTDesign:

• Pre-defined - select the nudge increment from the pre-defined options

• Custom - enter a custom vertical and horizontal nudge increment.

• Difference between selected objects - set the nudge increments to the horizontal 
and vertical difference between two selected objects (shown only when two 
objects are selected).

 To set the nudge increment:

• Click the Nudge tool button or select Nudge from the Tools menu.

• Either select a value from the Pre-defined value menu, or enter a value in the 
Horizontal and Vertical text boxes.

• Click the OK button.
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Once the nudge increment is defined, use the arrow keys on the keyboard to move selected 
objects one increment per press, in that direction.

For more information on Measurement Units see page 9.

Difference between Selected Objects automatically calculates and sets the nudge 
increment to the difference between two selected objects. This is handy if you want to create 
uniform space between text objects or lines.

To set the nudge distance to the difference between two selected objects:

• Select two objects on your form, either by clicking each of them while holding 
down the SHIFT  key or by drawing a marquee around the objects.

• Click the Nudge tool button or select Nudge from the Tools menu.

• Select Difference between selected objects from the Pre-defined values menu. 
The Horizontal and Vertical nudge values will be automatically calculated, as 
shown in the Nudge value box.

• Click the OK button.

Once the nudge increment is defined, you can use the arrow keys on the keyboard to move 
selected objects one increment per press, in that direction.

Nudge Tool Example

Use Difference between selected objects nudge option to create quantity columns that 
are equal in width.

• Select two column lines on the QTY ORD. column.

• Choose Nudge from Tools menu, or click on the Nudge tool button from the 
toolbar.

• Select Difference between selected objects from the Pre-defined values menu.
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• Click the OK button.

• Select the right column line and select Copy then Paste from the Edit menu, or 

click Copy tool  then Paste tool  from the Toolbar.

Note: Paste draws directly over the Cut or Copied object.

Press the right arrow on the keyboard. Now you have columns for QTY ORD. and 
QTY SHIP. that are equal in width.

Using the Alignment Tool

The Alignment tool allows selected objects to be exactly aligned to any other object on the 
page.

There are six alignment tools that can be used to manipulate single objects, multiple selected 
objects, or objects selected as a group.

 Left align - aligns the left side of the object.

 Horizontal center - aligns the object between two points horizontally.

 Right align - aligns the right side of the object.

 Top align - aligns the top side of the object.
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 Vertical center - aligns the object between two points vertically.

 Bottom align - aligns the bottom of the object.

When aligning objects, you must consider how the objects are referenced by the alignment 
tool. To align objects:

• Select the object to be aligned.

• Select the appropriated alignment tool.

• Click on another object which is used as a point of reference.

The second object, i.e. the reference object, is divided into four parts, a top and bottom half, 
and a left and right half. Alignment of the first object will depend on which part of the second 
object is used as a reference point.

Following are five examples of how to use the alignment tools:

Aligning Objects Example 1

Align the left side of an object to the left side of another object.

Select the object to be aligned.

• Select the Left alignment tool on the alignment toolbar.

• Click on the left side of the second object.
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The first object aligns itself to the left of the second object.

Aligning Objects Example 2

Align the left side of an object to the right side of another object.

• Select the object to be aligned.

• Select the Left alignment tool on the alignment toolbar.

• Click on the right side of the second object.

The first object left aligns itself to the right of the second object.
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Aligning Objects Example 3

Align the top of an object to the top of another object.

• Select the object to be aligned.

• Select the Top alignment tool on the alignment toolbar.

• Click on the top of the second object.

The first object aligns itself to the top of the second object.

Aligning Objects Example 4

Align the top of an object to the bottom of another object.

• Select the object to be aligned.

• Select the Top alignment tool on the alignment toolbar.
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• Click on the bottom of the second object.

The first object aligns itself to the bottom of the second object.

Aligning Objects Example 5

Horizontally center a selected object between the left and right sides of another object.

• Select the object to be aligned.

• Select the Horizontal center alignment tool on the alignment toolbar.
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• Click on the left and right sides of the second object.

The first object is horizontally centered between the left and the right sides of the 
second object.

 Stretch alignment enables you to stretch objects to fit between other objects, or to size 
them to other objects.

To enable stretch alignment, select the Stretch Alignment option from the Align under 
the Tools menu or click the Stretch Alignment tool button on the toolbar. Stretch 
alignment will remain enabled until the button is clicked again.

Using Stretch Alignment Example

Stretch the vertical line to fit the height of the rectangle.

• Select the object to be stretched.

• Enable the Stretching tool.

• Select the Vertical center alignment tool on the alignment toolbar.
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• Click on the top and bottom sides of the second object.

The first object (vertical line), is stretched to be the same height as the second object 
(rectangle).

Creating Page Elements
Page elements are defined before new objects are created.

• Base page is the only compulsory page element for a form design, and is cre-
ated by default for each new page. Data included on the Base page is typically 
that which identifies and heads the document, and appears on every page of the 
output.

• Detail Area contains Detail Lines that print repeated variable data.

• Sub-form is defined for the additional information that occurs only once in the 
data, such as an invoice total, or occurs repetitively as a "Ship to" address.

• Group headers print heading information that appears at the top of a group of 
detail lines and automatically at the top of subsequent pages for this group.

• Report header is used to print information which is needed only on the FIRST 
page of the document. Report footer is used to print information which is 
needed only on the LAST page of the document. This may include information 
such as the total of an invoice or a remittance advice slip.

• Page header is used for a "miniaturized" version of the header, typically omit-
ting address lines, thus creating extra space for details on all pages subsequent 
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to the first page. Page footer is often used to print C/Fwd details and is smaller 
than a report footer and so creates extra space for details on all pages previous 
to the last page.

• First Page footer is a special footer that will be printed on the first page only, 
such as printing a check (cheque) form.

• Second Page footer is a special footer printed on the back of a first page footer 
on duplex documents to prevent detail lines occupying a tear-off portion (such 
as a payment slip).

• The Carried forward and Brought forward page elements are special types of 
detail lines that, enable the carrying of totals across pages.

When a form design becomes complex, some page elements may appear to obstruct others or 
may even not fit on the page in the design window. You can define which page elements are 
currently visible on screen and in which order to place those visible elements from the 
Placement and visibility option in the Define menu.

Base Page

The Base page is used as a template for each new page and contains data common to all pages. 
Data included on the Base page is typically that which identifies the document, and appears 
on every page of the output.
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The figure below shows a sample Base page. It contains both constant objects (objects that 
always appear the same when printed) and variable objects (objects that obtain their value 
from the data). The logo and heading are constant objects while the customer address and the 
date fields are variable text objects. When the form prints, the same logo and heading will 
appear at the top of each printed page, however, the address and invoice number are 
extracted from the data and change with each new document.

When you create a blank form in FTDesign, you automatically start on the Base page.

To define the properties of the Base page:

• Ensure the Base page is selected on the Go menu.

• Select Properties of the Base page from the Define menu.

• On the Page Settings tab:
• Printer - use the Printer menu to select either a PCL or PostScript printer 

which you will use to design the form.
•  Paper type - select the appropriate page size from the Paper type drop down 

menu.
• Orientation - change the page orientation of the page by choosing Portrait or 

Landscape settings in the Orientation frame. Check the Reversed check box 
for the page to print reversed (from the bottom to the top).



91

• Margins - modify the page margins in the Margins frame.

• To create a custom paper type:
• Click the "..." button to create a custom page size.
• Give the custom page size a Name, Height, Width and PCL Escape. The 

PCL Escape is the code sent to the printer. The PCL escape code value can be 
found in your printer manual. Email support@formtrap.com for other 
non-standard paper instructions for PostScript and PCLXL.

• Choose measurement units for the defined paper size from the Units drop-
down menu.

• The Detail Area tab allows definition of the area of the form used for detail 
lines:
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• Offset from left - left margin, between the left edge of the Detail Area and 
the left of the page edge.

• Width - width of Detail Area.
• Number of columns - number of columns in Detail Area. Detail lines are 

added starting at the top of the first column, moving down to the end of the 
Detail Area. When the first column is filled, detail lines are added to the top 
of the second column and so on. Multiple columns are commonly used in 
label printing.

• Top of the area - margin between the top edge of the Detail Area and the top 
of the page.

• Bottom of the area - margin between the bottom edge of the Detail Area and 
the top of the page.

• Floating - tick the checkbox to allow the top or/and bottom edge of the 
Detail Area float depending on the size of that page's heading and trailers. 
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Note: The Detail Area is delineated by a faint grey outline, which can be adjusted 
using the mouse by pulling the handles. This facility is only available when 
the base page is in focus.

• The Copy Control tab allows definition of selected bins and/or multiple copies 
for up to five copies. This method requires manual decollation of copies and it 
is simpler to produce an alternate full copy using another similar form. (Copies 
are retained for backwards compatibility purposes).

• Configure each copy:
• Source - alter the paper tray FormTrap prints from.
• Destination - alter the output bin FormTrap prints to. If you are using a Post-

Script printer driver you will need to enter the name of the output bin in the 
Destination text box. This information can be found in your Printer manual.

• Stamp with - select a stamp/duplex sub-form from the dropdown menu to be 
stamped on this copy. Tick the Duplex checkbox to allow a stamped 
sub-form to be printed on the reverse of the page.

• Duplex with - select a stamp/duplex sub-form from the dropdown menu to 
be printed on the reverse of the page.

•  If you have defined a First Page footer, you can set different source and des-
tination bins for this copy.

• First Page Source - alter the paper tray FormTrap prints the first page 
from.

• First Page Destination - alter the output bin FormTrap prints the first 
page to. If you are using a PostScript printer driver you will need to 
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enter the name of the output bin in the Destination text box. This infor-
mation can be found in your Printer manual.

Note: A PostScript destination bin must be entered in English.

• On the Records tab, you can define the variables fields for the Base page. Form-
Trap can then properly extract the fields from the input file. This step is 
optional. Each field can also be defined as needed when the variable object is 
created.

For more information on Defining Variables in Print Line Mode see page 23.
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For more information on Defining Variables in Records Mode see page 31.
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Detail Area

The Detail Area is a bounding box surrounding the incoming variable data. A Detail Area 
needs to be defined as part of the Base Page if you intend to include the variable detail lines 
from the data file. The figure below outlines a sample Detail Area on a form.

There are two types of Detail Areas:

• Static - the Detail Area remains in the same position on each page.

• Floating - the Detail Area moves up and down the page and changes in size to 
provide room for Report and Page headers and footers.

Static Detail Area

To define a static Detail Area:

• Ensure the Base page is selected on the Go menu. Select Properties of the Base 
page... from the Define menu.

• Set the properties of Detail Area on the Detail Area tab.

• Un-tick both Floating checkboxes of Top of the area and Bottom of the area.

• Click the OK button. The Detail Area is delineated by a faint grey outline, 
which can be adjusted using the mouse by pulling the handles. This facility is 
only available when the Base page is in focus.
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Floating Detail Area

To define a floating Detail Area:

• Ensure the Base page is selected on the Go menu. Select Properties of the Base 
page... from the Define menu.

• Set the properties of Detail Area on the Detail Area tab.

• Tick the Floating checkbox next to Top of the area to make the top edge of the 
Detail Area float. The top of the Detail Area moves up and down to cater for the 
Report and Page headers.

• Tick the Floating checkbox next to Bottom of the area to make the bottom 
edge of the Detail Area float. The bottom of the Detail Area moves up and 
down to cater for the Report and Page footers.

• Click the OK button.

Detail Lines

Detail lines represent the repeating information in a form, which may be of different 
structures. In an Invoice you may have product lines, comment lines, tax lines and so on, all 
are detail lines.

To define a Detail Line:

• Select Add detail line from the Define menu.

• On the Settings tab set:
• Name - the name is used as a reference for the detail line.
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• Height - set the height of the detail line to accommodate the text objects that 
represent the detail information and any formatting objects such as extra 
lines or boxes.

• Page break before - a new page is generated before the detail line prints 
(used for internal detail-level headers within the document).

• Page break after - a new page is generated after the detail line prints (used 
when totals other than document totals are included within the detail lines).

• Widow/Orphan - the widow/orphan value defines the minimum amount of 
remaining space that must be available at run-time in the Detail Area in order 
for the detail line to be printed. If the available space is less than the space 
required by the widow/orphan value, the detail line will not be printed on this 
page and will instead be carried to the next page. This is used for 
within-detail-area structures so as not to show just a header and/or total on a 
page by itself.

• Record mode identifier - a letter of the alphabet (uppercase) used to uniquely 
identify the detail line (only applicable in Records Mode).

• On the Advanced tab:
• Implicit header - an existing implicit header can be associated with the detail 

line. When the assigned detail line is first found in the data the implicit group 
header prints the table object for that group of detail lines, before printing the 
associated detail line.

• Growing and Shrinking - detail lines can be defined to dynamically resize at 
run-time in order to accommodate variable text or other objects within the 
detail. This is most useful when text objects on the detail contain multiple 
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fields, which can result in paragraphs with a varying number of lines, 
depending on the input data.

Detail lines defined as being of variable size can also have an arbitrary amount of white 
space set to follow the printed detail. For example, this feature ensures a consistent 
space between paragraphs on a letter form.

Tick the Variable height checkbox and enter a value in the White space text box. This 
creates a margin between the current detail line and the next detail line.

• On the Records tab, define the fields for this detail line. FormTrap can then 
properly extract the data from the input file.

For more information on Defining Variables in Print Line Mode page 23.
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For more information on Defining Variables in Records Mode see page 31.
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Sub-forms

Sub-forms are used to print conditional information that may occur only once in the input 
file.

To add a new sub-form:

• Select Add sub-form from the Define menu.

• On the Settings tab set:
• Name - the name is used as a reference for the sub-form.
• Record mode identifier - a number (1 through 9) used to uniquely identify 

the sub-form (only applicable in Records Mode).
• Page break before - a new page is generated before the sub-form prints.
• Page break after - a new page is generated after the sub-form prints.
• Keep data - when the sub-form is found in the input file, the sub-form is then 

repeated on subsequent pages until a new document (Base page or 0 record) 
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appears in the data. Often used for Ship To instructions which may be present 
or absent.

• On the Records tab, define the fields for the sub-form. FormTrap can then prop-
erly extract the data from the input file.

For more information on Defining Variables in Print Line Mode page 23.
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For more information on Defining Variables in Records Mode page 31.

Stamp/duplex Sub-forms

Stamp/duplex sub-forms, used with the Copy control feature, allow different text or graphics 
to be printed on each of the multiple copies of the form.

• A stamp is printed on the front of each page. For example, create an accounts 
copy stamp which prints on the front of each page.

• A duplex is printed on the reverse of the page. For example, create a terms and 
conditions sub-form which prints on the reverse of each page.

To add a new stamp/duplex sub-form:

• Select Add stamp/duplex from the Define menu.

• On the Settings tab, define a name for this stamp/duplex sub-form.

Group Headers

Group headers print heading information that appears at the top of a group of detail lines and 
automatically at the top of subsequent pages for this group. There are two types of group 
headers:

• Explicit group header - an explicit group header is found in the input file and 
consists of constant or variable heading information.

• Implicit group header - an implicit group header is assigned by FormTrap to a 
detail line and consists of constant heading information.
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Explicit group header

An explicit group header is found in the input file. On a records mode form, when explicit 
group headers are created they are assigned a letter of the alphabet, lowercase a through j, as 
a unique identifier. When FormTrap sees an a - j identifier in the first column of the input file 
record it will print the corresponding explicit group header.

To add an explicit group header:

• From the Define menu, select Add group header and then Explicit.

• On the Settings tab, set:
• Name - the name is used as a reference for the group header.
• Height - set the height of the group header to accommodate the variable or 

constant text objects that represent the detail information and any additional 
formatting objects.

• Footer - space between the end of the current table object and the next table 
object.

• Has table object - table for the current group of detail lines is printed with 
the group header.

• Page break before - a new page is generated before the group header prints.
• Record mode identifier - a letter of the alphabet (lowercase) used to uniquely 

identify the detail line (only applicable in Records Mode).

• On the Records tab, define the fields for the group header. FormTrap can then 
properly extract the fields from the input file.

For more information on Defining Variables in Print Line Mode page 23.
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For more information on Defining Variables in Records Mode page 31.

Implicit group header

An implicit group header contains constant heading information and prints at the top of a 
group of detail lines. The implicit group header is associated with a specific detail line or a 
group of detail lines. When that detail line is first found in the input file, the implicit group 
header will print before the detail line as a group heading.

To add an implicit group header:

• From the Define menu, select Add group header and then Implicit .

• On the Settings tab, set:
• Name - the name is used as a reference for the group header.
• Height - set the height of the group header to accommodate the constant text 

objects that represent the detail information and any additional formatting 
objects.

• Footer - space between the end of the current table object and the next table 
object.

• Has table object - table for the current group of detail lines is printed with 
the group header.
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• Page break before - a new page will be generated before the group header 
prints.

After the implicit group header is defined it is then associated with a detail line.

Has table object

If the Has table object box has been checked FormTrap will create a table using the 
associated explicit or implicit group header at the top of the table. The table object will create 
a border around the Detail Area. If a new explicit or implicit group header is called the current 
table object terminates and a new table object with a new header is created.

The newly created group header is outlined by a black rectangle. This black rectangle 
represents the table object and its properties can be edited to change the color and style of the 
table printed. The table object columns can also be created and positioned graphically on your 
form.

To edit the table object:

• Double click on the table object.

• On the Settings tab set:
• Border - set the border style to Thin, Thick or Double.
• Rounded at the top - check the box to give the top of the table rounded cor-

ners.
• Rounded at the bottom - check the box to give the bottom of the table 

rounded corners.
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• Colors - select a section of the table, e.g. border color, and then click the 
Edit... button to change the color of the section. Click the Transparent but-
ton to make that section of the table transparent.

• Fill Detail Area - check the box to have the table fill to the end of the Detail 
Area, regardless of how many detail lines are printed on the page.

• On the Columns tab, add and modify the columns for the table. You can also 
create and reposition column lines graphically on the form itself.
• Add - click the Add button to add a new column and enter the column width.
• Edit - select a column and click the Edit button to edit the column width.
• Delete - select a column and click the Delete button to delete a column.
• Space evenly - click the Space evenly button to make all columns an equal 

width.
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• Keep proportional - if checked, the columns within the table object remains 
proportional when the object is resized.

• Click the OK button.

To edit the table object columns graphically on your form:

• Right click on the table object and select Edit Columns from the dropdown 
menu.

• Right click and select Insert Columns.

• Click within the table object to insert a new column line. Continue to insert as 
many column lines as you need in your table object.

• Once you have finished inserting columns, right click within the table object 
and select End Inserting Columns from the drop down menu. You can insert 
new column lines by right clicking and selecting Insert Columns from the drop 
down menu.

• To move a column line within the table object, click to select the column line 
and drag it to the desired position or use the arrow keys on your keyboard to 
nudge the line.

• Once you have finished editing the columns in the table object, right click 
within the table object and select Accept Changes to save the changes to the 
table object columns, or Cancel Changes to discard the changes to the table 
object columns.
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Report Header

The Report header is used to print information which is needed only on the first page of the 
document. On an invoice, this may include specific document information such as the credit 
terms, bill of lading or sales people. The figure below outlines a sample Report header on a 
form.

Fields from the input file for Report Headers and Footers and for Page Headers and Footers 
must be defined in the Base Page first.

For more information on Defining Variables in Print Line Mode see page 23.

For more information on Defining Variables in Records Mode see page 31.

To create the Report header:

• Select Report header from the Define menu.

• On the Settings tab set:
• Height - a height for the Report header.
• Print on all pages - check this box for the Report header to print on all pages. 

This makes the Report header a Page header.
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• On the Accumulative fields tab, define the accumulative fields Name, and set 
the data fields to be accumulated from the page elements.

Report Footer

The Report footer is used to print information which is needed only on the last page of the 
document. This may include information such as the total of an invoice or a remittance advice 
slip. The figure below outlines a sample Report footer on a form.

To create the Report footer:

• Select Report footer from the Define menu.

• On the Settings tab set:
• Height - height for the Report footer.

• On the Accumulative fields tab, define the accumulative fields Name, and set 
the data fields to be accumulated from the page elements.
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Page Header

The Page header is typically smaller in size than the Report header. It is used to create extra 
space for details on all pages subsequent to the first page, as these pages typically do not 
require the same level of detail as covered by the Report header. For instance, a Page header 
would typically only carry basic customer and document information as well as the page 
number.

To create the Page header:

• Select Page header from the Define menu.

• On the Settings tab set:
• Height - height for the Page header.

• On the Accumulative fields tab, create a new accumulative field if not already 
defined.
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Page Footer

The Page footer is typically smaller in size than the Report footer. It is used to create extra 
space for details on all pages previous to the last page, as these pages typically do not require 
the same level of detail, if any, as covered by the Report footer.

To create the Page footer:

• Select Page footer from the Define menu.

• On the Settings tab set:
• Height - height for the Page footer.

• On the Accumulative fields tab, create a new accumulative field if not already 
defined.

First Page Footer

The First Page footer is a special footer printed on the first page only. If defined, it replaces 
the Page footer on the first page and is typically used to print a check (cheque), allowing you 
to print the first page on check stationery and the remaining pages on plain paper. You can set 
different source and destination bins in Copy control for the First Page footer (only possible 
if a First Page footer has been defined).
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To create the First Page footer:

• Select First Page footer from the Define menu.

• On the Settings tab set:
• Height - height for the First Page footer.

• On the Accumulative fields tab, create a new accumulative field if not already 
defined.

Second Page Footer

The Second Page footer is a special footer printed on the second page only. If defined, it 
replaces the Page footer on the second page and is typically used for duplex documents on the 
back of a first page footer to prevent detail lines on a tear-off remittance or check (cheque).

To define a Second Page footer:

• Select Second Page footer from the Define menu.

• On the Settings tab set:
• Height - height for the Second Page footer.
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• On the Accumulative fields tab, create a new accumulative field if not already 
defined.

Carried Forward

Carried forward and Brought forward page elements are optional special detail lines that are 
printed automatically by FormTrap. As their names suggest, these detail lines enable 
progressive totals across pages. While both can print constant objects, variable data can only 
come from the accumulative field or the Base page. A Carried forward is unusual, this 
information is normally shown in a Page Footer. Brought forward is common and usually 
contained within the detail area.

If defined, the Brought forward detail will print as the first line in the Detail Area of every 
page except the first. Similarly, the Carried forward detail will print as the very last line in the 
Detail Area of every page except the last.

To add a Carried forward detail:

• Select Carried forward from the Define menu.
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• On the Settings tab, set the Height for the line. Tick the Print inside group 
checkbox to print the Carried forward detail inside the table object.

• On the Accumulative fields tab, create a new accumulative field if not already 
defined.

• Click the OK button.

• Constant objects can now be added in the same way as for other detail lines. 
Variable objects can be linked to existing accumulative fields.

Brought Forward

Carried forward and Brought forward page elements are optional special detail lines that are 
printed automatically by FormTrap. As their names suggest, these detail lines enable 
progressive totals across pages. While both can print constant objects, variable data can only 
come from the accumulative field or the Base page. A Carried forward is unusual, this 
information is normally shown in a Page Footer. Brought forward is common and usually 
contained within the detail area.

If defined, the Brought forward detail will print as the first line in the Detail Area of every 
page except the first. Similarly, the Carried forward detail will print as the very last line in the 
Detail Area of every page except the last.

To add a Brought forward detail:
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• Select Brought forward from the Define menu.

• On the Settings tab, set the Height for the line. Tick the Print inside group 
checkbox to print the Brought forward detail inside the table object.

• On the Accumulative fields tab, create a new accumulative field if not already 
defined.

• Constant objects can now be added in the same way as for other detail lines. 
Variable objects can be linked to existing accumulative fields.

The Accumulative Field

Accumulative fields progressively accumulate data from other fields on a FormTrap 
document. Typical use is to accumulate running totals of data from detail lines such as line 
amounts. Data is accumulated at the time of printing the original field, hence if a detail field 
prints more than once (two-up invoices for example), two versions of the data field MUST be 
defined, with one name used for a single accumulation.

The page elements Report header and footer, Page header and footer, Carry 
forward, and Brought forward have the access to the accumulative field.
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Your document can have any number of accumulative fields. The Report header, Page 
header and Brought forward page elements will print the value of the accumulative field 
from the completed previous page. The Page footer, Report footer and Carry forward 
page elements will print the value of the accumulative field as it stands upon completion of 
the current page.

To create an accumulative field:

• Select the appropriate page element on the Go menu.

• Select Properties of... from the Define menu.

• On the Accumulative fields tab, click on the New... button to add a new field.

• A new field appears in the Name box. Left-click once to select and then type in 
a unique name.
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• In the right-hand box is a list of all page elements and the data fields within 
each page element. Select the data field(s) that you wish to accumulate.

• The accumulative field is now available in the list of records when defining a 
new variable object.
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• Click on the Properties... button. Rename the field, and/or change the reset 
attributes as required:
• Reset on new page - the value accrued in the accumulative field resets to 

zero at the beginning of a new page.

Note: Accumulative fields on the Report header, Page header and Brought forward 
page elements print before the value is reset.

• Reset on new group - the value accrued in the accumulative field resets 
when a new Group header is printed.

Deleting Page Elements
To delete a page element:

• Ensure the page element to be deleted is selected on the Go menu.

• Select Delete... from the Define menu.

• Click Yes in the confirmation pop-up.

Base page is the only page element that cannot be deleted.

Note: Consider saving the form under an "old-" name before deleting a page 
element, as this process cannot be undone.
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Arranging Page Elements

Structure Map Pane

The Structure Map Pane lists the page elements that have been created and the variables 
associated with that page element. The Structure Map Pane is located in the left bottom panel 
of your FTDesign window.

 Mapped Unlinked variable - field is not linked to a variable on the form but has been 
mapped to a field in the data (green broken link). 

 Mapped Linked variable - field is linked to a variable on the form and is associated with a 
field in the data (green link).

 Unmapped Unlinked Variable - field is defined but not linked to a variable on the form 
nor mapped to a field in the data (grey broken link).

Unmapped Linked Variable - field is linked to a variable on the form but is not associated 
with a field in the data (grey link). This condition is flagged as an error when trying to preview 
a form or build a project. You must link all form variables to data prior to building the project 
or previewing the form.

Navigating between Page Elements

To swap between page elements:
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• Select the element you wish to swap to on the Go menu.

• Alternatively, right click on the element in the Structure Map Pane and select 
Go from the drop down menu.

Placement and Visibility

When a form design becomes complex, some page elements may obstruct others or may even 
not fit on the page in the design window. FTDesign adds page elements to the page in the 
order you create them. If, for example, you add a group header after creating a detail line, it 
can be difficult to correctly align text to the appropriate header text.

To cater for these situations, FTDesign allows you to define which page elements are currently 
visible on screen and in which order to place those elements. You can control this from the 
Placement and visibility option in the Define menu.

Note: This option has no influence on the order of page elements produced at 
run-time.

To adjust the Placement and visibility:

• Select Placement and visibility from the Define menu.

• On the Headers / footers tab:
• Available - headers and footers in the Available box will not appear on the 

form in FTDesign. Although the headers and footers in the Available box do 
not appear on the form, they will still print at run-time.

• Ordered - headers and footers in the Ordered box will appear on the form in 
the same sequence.

• Right/Left arrows - use the right and left arrows to move headers and footers 
between the Available and Ordered boxes.
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• Up/Down arrows - use the up and down arrows to change the header and 
footer order in the Ordered box.

• On the Detail lines tab:
• Available - detail lines in the Available box will not appear on the form in 

FTDesign. Although the details lines in the Available box do not appear on 
the form, they will still print at run-time.

• Ordered - detail lines in the Ordered box will appear on the form in the same 
sequence.

• Right/Left arrows - use the right and left arrows to move detail lines between 
the Available and Ordered boxes.

• Up/Down arrows - use the up and down arrows to change the detail line 
order in the Ordered box.

• On the Sub-forms tab:
• Sub-forms - in the sub-forms box check or uncheck the check box to make 

the sub-form visible or not visible.
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• Show All - click the Show All button to make all sub-forms on the form visi-
ble.

• Hide All - click the Hide All button to make all sub-forms on the form not 
visible.
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Masking and Font Change

FormTrap uses a number of special features that give you extra control over the appearance of 
the final document.

• Masking gives you extensive control over the formatting of output text, particu-
larly for dates and currency.

• Replace fonts provides a function to replace fonts in your form. It is a conven-
ient way of making global changes to fonts used in the form.

This chapter explains the two features in more depth. 

Masking
Masking is the process of controlling and changing the appearance of selected variable fields. 
You can take a field from the data and modify its appearance to suit your own purpose. For 
example, you can remove leading or trailing zeros, or turn zeros into spaces.

This section covers how to mask dates, currency and how to create and apply a custom mask.

Masking Dates

FormTrap can apply date masking to data fields of up to 10 characters.

Apply Date Mask

To apply date masking:

• Create a new variable text object or edit an existing variable text object.

• On the Link to field dialog box, select Date from the Mask as drop down menu.

• Select the original date type (date format in the data) from the Input format 
menu.

• Select the desired date type from the Output format menu.

• If you are using a an all-numeric format, select a date separator from the Short 
date separator menu.

• Underneath Year, check either the Two digit or Four digit year option.

• Click the OK button to apply the mask to the field.

CHAPTER 5 
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Note: It is important that the Input format chosen in FTDesign matches the format 
from the input data. If not, the output on the form displays an error message, 
such as "Invalid day: 2009", or displays the wrong date.

If you want to show the date in another format, select Output format as Language 
dependent and select the language required per this screen shot.
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Language is the language used for alphabetic Month and Day names.

Custom must be selected to define your own version of the output date.

Various combinations of d (day), M (month - capital letter) and y (year) produce these 
results:

Masking Currency

FormTrap formats the input field according to the specified currency mask. There are a 
number of currency masks to choose form. These include:

Amount/Numeric - formats numeric fields into numbers or amounts, inserting currency 
symbol, separators and negative signs.

Price - formats numeric data fields using a price format, suitable for supermarket shelves as 
it shows values under $1.00 as 77 cents.

Wordy - transforms numeric data fields into words, assuming a dollar and cents format 
(depending on the currency format selected).

Units - transforms the first numeric character in the data field into words.

Cents - displays the cents portion of the numeric data field.

Amount/Numeric

With amount mask, FormTrap formats the data by inserting a currency symbol and 
separators / decimal symbols. FormTrap determines whether the data is positive or negative 
by searching for these characters: -, Cr, CR, Dr, DR and ( ).

To apply Amount/Numeric masking:

• Create a new variable test object or edit and existing variable test object.

• On the Link to field dialog box, select Amount/Numeric form the Mask as 
menu.

• On the Input tab, select one of the following currency input types:
• Use decimal separator - FormTrap finds the decimal point in the field.
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• Assume two decimals - the last two digits of the field are used.

• On the Currency tab, select the currency symbol from the currency symbol 
from the pull down list, or press delete and key your own curency symbols(s) - 
e.g. SF for Swiss Francs.
• On right - the currency symbol appears on the right of the masked value.
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• Extra space - an extra space is inserted between the currency symbol and the 
masked value.

• On the Separators tab, select the separators for thousands and decimals.
• Thousands - select from a comma, full stop, space or have nothing to signify 

the decimal point.
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• Decimals - select from a comma, full stop, space or have nothing to signify 
the decimal point.

• On the Numbers tab, select the credit symbol and the number of decimals.
• Symbol - select the symbol used to indicate whether the value is a credit.
• Extra space - check this box to insert a space between the value and the 

credit symbol.
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• Number of decimals - the number of decimal places used on the formatted 
value.

• Click the OK button to apply the mask to the field.

Price

The price mask is included for backward compatibility with the currency mask preferred. 

Wordy

The wordy mask transforms numeric extract fields into words, assuming a dollar and cents 
format. This mask is used when printing check (cheque) forms.

To apply wordy masking:

• Create a new variable text object or edit an existing variable text object.

• On the Link to field dialog box, select Wordy from the Mask as menu.

• Select the appropriate language from the Language menu.

• Select one of the following currency input types:
• Use decimal separator - FormTrap finds the decimal point in the field.
• Assume two decimals - the last two digits of the field are used.
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For more information on Word Wrap see page 53.

Units

The units mask transforms the first numeric character from the data field to words.

This is especially useful when creating checks (cheques) where the check amount is split into 
hundreds of thousands, tens of thousands and so on. In the example below, you need to define 
each character of the input data separately.

To apply units masking:

• Create a new variable text object or edit an existing variable text object.

• On the Link to field dialog box, select Units from the Mask as menu.
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• Select the appropriate language form the Language menu.

Cents

The cents mask displays only the cents portion of a numeric data field. This mask is most 
often used on check (cheque) forms.

To Apply cents masking:

• Create a new variable text object or edit an existing variable text object.

• On the Link to field dialog box, select Cents from the Mask as menu.

• Select the appropriate language form the Language menu.

• Select one of the following currency input types:
• Use decimal separator - FormTrap finds the decimal point in the field.
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• Assume two decimals - the last two digits of the field are used.

Custom Mask

The custom mask allows you to create your own format to tailor the way information is 
displayed on the finished form. This function is especially useful for displaying codes, 
constructing special currency formats and incorporating text within variable data.

Create a custom mask

To create a custom mask:

• Create a new variable text object or edit an existing variable text object.
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• On the Link to field dialog box, select Custom from the Mask as menu.
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• In the Mask text box type in the mask required, using the underscore to mark 
the exact placement of the characters from the original field. It is important to 
enter enough underscores to represent the maximum field size.

• Click the OK button to apply the mask.

Using suppression you can then remove unwanted spaces or leading zeros from your data 
field.

Custom mask with left suppression:

In the following example we remove leading zeros from the customer number field.

To create a Custom mask with left suppression:

• Create a new variable text object or edit an existing variable text object.

• On the Link to field dialog box, select Custom from the Mask as menu.
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• In the Mask text box, type in the mask required. Enter an underscore to repre-
sent each character in the input field. It is important to enter enough underscores 
to represent the maximum field size.

• In the Mask text box, highlight the area where the leading zeros or spaces will 
appear. Click on the Left button. The highlighted area will change color. The 
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purple highlight indicates the start of the suppression and the blue highlight 
indicates where left suppression will occur.

• To delete the suppression, highlight the area of the suppression mask you wish 
to delete and click the Delete button.

• Check the Suppress spaces only if you want to suppress only leading or trailing 
spaces from the data field.

• Check the Space replace suppressed character if you want to replace sup-
pressed characters with spaces. This is useful if you want to keep alignment as 
is.

Custom mask with right suppression

In the following example we remove a trailing space from the company name variable.

To create a custom mask with right suppression:
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• Create a new variable text or object or edit and existing variable text object.

• On the Link to field dialog box, select Custom from the Mask as menu.

• In the Mask text box type in the mask required, using the underscore to mark 
the exact placement of the characters from the original field. It is important to 
enter enough underscores to represent the maximum field size.

• In the Mask text box, highlight the area where the trailing spaces will appear. 
Click on the Right button. The highlighted area will change color. The purple 
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highlight indicates the start of the suppression and the red highlight indicates 
where right suppression will occur.

• To delete the suppression, highlight the area of the suppression mask you wish 
to delete and click the Delete button.

• Check the Suppress spaces only if you want to suppress only leading or trailing 
spaces from the data field.

• Check the Space replace suppressed character if you want to replace sup-
pressed characters with spaces. This is useful if you want to keep alignment as 
is.

Replacing Fonts
FTDesign provides the function to replace fonts used in your form. It is a convenient way of 
making global changes to fonts used in the form. This saves you from manually changing each 
instance of a font.

How to replace fonts

To replace fonts:

• Select Replace Fonts in the Tools menu.
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• In the Font replacement dialog box, click the Add button.

• In the Add fonts to table dialog box, choose from the Currently used font list 
the font to replace.

• Choose the font you with to exchange to from the Font that will be used instead 
list. This list contains all available fonts.

• Click the OK button to add the chosen conversion to the Font replacement table.
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• Click the OK button in the Font replacement dialog box to make the changes.
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Projects

A project is a file that carries a form or a group of forms and other indicated files (fonts, 
graphics) and settings. One FormTrap load (.asc) file is created from each project.

• The project window appears on the left side of the FTDesign window.

• The project name appears at the top of the project window beneath the project 
toolbar.

• Files in the project are listed.

You can perform the following functions using the project toolbar.

Creating a New Project
To create a new project:

• Select New Project from the File menu. Project Definition wizard is launched.

CHAPTER 6 

Tool Description

Add files to project tool - add form(s) to the project

Remove files tool - remove a form from the project

Project Properties tool - edit the properties of the 
project
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• Enter an appropriate name in the Project name text box.

• Click the browse "..." button to locate the project. The default project file loca-
tion is defined in Design Options, Folders tab.

• Click the Next button to continue.
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• Enter a name for the load (.asc) file in the Output text box. By default it carries 
the same name as your project.

• Click the browse "..." button to locate the load (.asc) files when they are created 
by the build process. The default load files location is defined in Tools, Options, 
Folders tab.

• To add one or more existing forms to the project:
• Click the Add button and browse to the forms' location.
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• Select the form(s) you wish to add to the project. Select multiple forms by 
clicking each of them while holding down the CTRL key.

• Click Open.

• If you have not designed any forms yet, you can skip this step and add them 
later.

• Click the Next button to continue.

• Configure the Project Options.

• Click Finish to complete the project definition.

Project Sett ings

Project Files

To edit a Project:
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• Choose Settings from the Project menu or click the Project Properties tool but-
ton on the project toolbar. The Project dialog box opens.

• On the Project tab:
• Modify the name of the load (.asc) file in the Output box.
• Modify the location of the load (.asc) file in the Output location box.
• Click the Add button to add a form to the project. Alternatively, choose Add 

files from the Project menu, or click the Add files to project tool button on 
the project toolbar.

• Select an unwanted form and click the Remove button to delete the form 
from the project. Alternatively, click the Remove files tool button on the 
project toolbar to delete highlighted form(s).

To add a new form to the project:

• Select New form from the Project menu.

• Choose the Extract mode and click OK.

• On the Save As dialog box, give the new form a name and click the Save button.

• The new form is now part of the project.
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Project Options

To edit the Project Options:

• Choose Settings from the Project menu or click the Project Properties tool but-
ton on the project toolbar. The Project dialog box opens.

Project Defaults

Project defaults are used to initialize newly created projects and when the stand-alone form is 
viewed using the preview options.

On the Project defaults tab, you can set the following Font usage and MICR options:

• All  - FormTrap uses a combination of True Type fonts and printer-resident fonts 
when designing and building your form. Once All  is selected you can then set 
the following options:
• Prefer True Type Fonts - defaults to True Type fonts on all new projects. 

FormTrap uses True Type fonts instead of printer-resident fonts when both 
are present i.e. font 'Arial' exists both as a printer-resident and system based 
True Type font). Prefer True Type Fonts is the default option. Uncheck this 
box to default to printer-resident fonts on all new projects.

• Always build fonts - when FormTrap cannot find either the True Type or 
printer-resident fonts it will substitute the next best fit for the missing font. 
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Check this box to ignore font related errors or when the exact appearance of 
text glyphs is irrelevant.

• Printer - FormTrap uses only printer-resident fonts when designing and build-
ing your form. Printer-resident fonts are installed on the printer. Once Printer is 
selected, you can then set the following option:
• Post Script Level 1 - produces Postscript Level 1 output files. This option is 

generally used for specific faxing solutions that require Postscript Level 1 
input.

• System - FormTrap uses only True Type fonts when designing and building 
your form. True Type fonts are installed in your Windows font directory.

• Add Unicode subranges - this allows you to include additional ranges of char-
acter glyphs into your load (.asc) file. Subranges are supplied by TCG during 
the installation and on request. To add a new Unicode subrange:
• Click the Add button. The Unicode subranges dialog box will open.
• Select from the list of available subranges and click the OK button.
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• MICR - Select a default MICR file for all new projects. The MICR box refers to 
the location of the MICR font file you are using to generate the MICR line on 
check forms. The MICR font is only available when using a PCL printer driver 
to design and build forms.
• Click the browse "..." button and locate the MICR directory.
• Select the correct MICR file and click the OK button.
• If you are not producing checks (cheques) or you are not using the PCL 

printer driver you can ignore this option.

Building the Load ( .asc) File 
The load (.asc) file contains all the forms, settings and subsidiary files that make up the 
project compressed into a single file. This file can then be transferred to any production 
environment in which FormTrap is running, and the forms "loaded" from it as a "data file", 
once only.

To build a load (.asc) file in FTDesign:

• Open the project you wish to build.

• Select Build... from the Project menu. Any forms that are currently open in 
FTDesign are automatically saved.
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• It is important to note which printer driver is selected before building the forms 
into a load file. The type of printer driver will determine whether the load file is 
PCL or PostScript.

• The build dialog will appear on screen and log the build process. You can cancel 
the build at any time by clicking the Cancel button. When the build is finished 
the log will indicate whether the Load file is in PCL or PostScript format. Click 
Close to complete the build.

• The load (.asc) file will be written automatically to the location specified in the 
project options.

Warnings and Errors in the Build Process

The build process may produce Errors (shown in Red) which abort the Build process. 
Warnings (shown in Blue) allow the process to complete. Scroll through the list to see 
details on completion of the build. Most warnings are about "possible" differences in internal 
fonts compared with True Type fonts or between different models/manufacturers and are 
unlikely to be true these days.
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If any data fields on the form have not been mapped, the process aborts immediately with a 
message as shown:
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Testing and Viewing

Before creating your load (.asc) file, you can test your forms using FTPreview. FTPreview 
simulates a production print run using the .asc file and a sample print stream. 

Preview the Form

Load a Data File

To Load a Data File:

• Select Load data file... from the Tools menu.

• In the Open dialog box, select the data file you wish to use as a sample.

• Select the appropriate Ascii/Unicode conversion option:
• Auto - If necessary, FTDesign automatically converts the selected sample 

data file to Unicode based on your current system locale.
• Custom - Choose a custom filter to convert the data file. Click the Filters... 

button and the Input Filters dialog box will open. Click Add and select a fil-
ter to be used for conversion.

• None - No conversion filter is used.

• Click the Open button to load the sample data file.

CHAPTER 7 
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The choice of Auto or Custom depends on the Locale of your machine (the language it 
operates in) and the language of the data file. If these are the same (Simplified Chinese for 
example) AND you have that filter loaded, Auto will suffice. If these are different (English 
Locale with Korean data), then you will need to chose Custom and select the appropriate 
Filter for the language of the data file. The Western filter is applied for all Roman languages 
(English, and European languages).

Preview the Forms

To preview your form:

• Select FTPreview (b&w) or FTPreview (color) from the Tools menu.

• FTPreview appears with the sample data file formatted with the current form.
• PCL Preview - if you have selected a PCL printer driver to preview the form, 

the preview will be in b&w PCL format. If you selected FTPreview (color) 
color objects will appear as "blobs".

• PCLXL (PCL6) - if you have selected a PCLXL (PCL6) printer to preview 
the form, the preview will be in color or b&w depending on your preview 
selection. This is a TCG-written routine and allows the option "Print to ANY 
Windows Printer" in the production system.

• PostScript Preview - if you have selected a PostScript printer driver to pre-
view the form, the preview will be via Adobe PDF viewer in color PDF for-
mat for FTPreview (color), or black and white PDF for FTPreview (b&w).

If a data file has not been loaded to use as sample input FormTrap will not be able to preview 
the form.

For more information on Configuring FTPreview in Design Options page 15.

Save the Output File

Preview files... shows details from the prior preview, meaning you can view the Log file 
produced by the formatting program and save the output file.

Output files are named out with extensions .pcl, .pclxl (pcl6) and .ps.
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Repaginator

The FormTrap Repaginator works with Print Line Extract data, rearranging and removing 
input print lines to produce one page of output per document with all redundant lines 
removed. Output from the Repaginator allows easier design of your FormTrap document, and 
allows you to take advantage of the more advanced features.

For more information on the Properties of the Data File see page 21.

There are two ways to launch the FormTrap Repaginator:

• To launch the Repaginator from within FormTrap:
• Open your form and load a sample data file in FTDesign.
• Select Printline repaginator from the Tools menu, or click the Repaginator 

tool button on the top left corner of the Printmap window.

• To launch the Repaginator independently:
• Browse to your FTDesign directory in Windows Explorer. By default, your 

FTDesign directory is located under C:\Program Files\TCGIS\.
• Double click on the Repaginator executable named Rpg.exe to launch the 

Repaginator.

Repaginator Workspace

Repaginator consists of three windows:

• Areas Window - contains a list of the defined entries and areas.

• Mapping Window - displays the sample data, onto which you can map the areas 
and rules.

CHAPTER 8 
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• Rules Window - displays the rules you have created for the selected entry.

Load a Sample Data Fi le
Before creating your repagination rules you need a sample data file open. If FTDesign had a 
sample data file loaded it is displayed, otherwise open a sample data file. You can change the 
sample data file at any time by opening a new sample data file.

To open a sample data file to create your repagination rules with:

• Select Open Data File from the File menu or click the Open data file tool but-
ton on the toolbar.

• The Open dialog box opens. Browse and select the sample data file you wish to 
open.
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• Select one of the Ascii/Unicode conversion options. Auto is the normal option.

• Your sample data file will now be loaded into the Mapping window of the 
FormTrap Repaginator.

Entry

New Entry

General processing for a new file is to identify these areas, in this order, per document:
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• Header for the first page, including either a Change rule on the document 
number (eg. Invoice Number) or a rule selecting page 1 (and not page 10, 11 
and so on).

• Footer (if a footer exists), including a rule to identify the footer proportion of 
the form.

• Unwanted Detail lines (Properties, Suppress output) for the following, all with 
rules:
• Subsequent page headers (segregated by not having the change rule or page 1 

rule applying).
• Unwanted lines such as trailer, "continued" brought forwards and so on.

• Detail lines that are not blank to capture all of the remaining data except blank 
lines.

Your final file should have one page of output containing Header, Trailer and relevant detail 
lines as one long page.

Header Area

The header area holds text that outputs at the top of your repaginated data file and should 
include all of the header information, down to and including any title lines. You may have a 
raw data file that contains two purchase orders, each purchase order spanning multiple pages. 
The output of the repagination process must contain two headers, one for each purchase 
order.

To insert a new header area and hence a new entry:
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• Select New Entry - Header area from the Insert menu or click the Insert docu-

ment header tool  button on the toolbar.

• Highlight the area in the Mapping window that represents your document 
header and release the mouse button. The header area is displayed in red and 
your entry and header listed in the Areas window.

You would now set up rules to identify the Header.

Footer Area

The footer area holds the total information for the document and is therefore optional as 
some documents may not have totals. The footer area is inserted directly after the header area 
in the output from the repagination process. This allows you to define footer fields on the Base 
page of your FormTrap form. It also removes the hassle of having floating totals in your data 
file, making forms design much simpler. You may only define one footer area.

To create a footer area for this entry:

• Select Footer area from the Insert menu or click the Insert document footer 

tool  button on the toolbar.
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• Highlight the text in the Mapping window that represents your document footer 
and release the mouse button. The footer area is displayed in green and your 
footer listed in the Areas window.

You would now set up rules to identify the Footer.

Data Area

Data is generally defined by first identifying the items you do NOT want, then accepting 
everything else that is not blank. After creating the header and footer, you need to identify 
data lines that are redundant. These are the line sets to be removed:

• Subsequent page headings

• Continued and Carried forward messages

• Underlines

• Total texts that are redundant

You can then accept all remaining lines with a simple "not blank" test.

To create a data area in your entry:

• Select Data area from the Insert menu or click the Insert document detail line 

tool  button on the toolbar.
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• Highlight the line(s) in the Mapping window that represent a data area and 
release the mouse button. The data area is displayed in purple and your data 
area listed in the Areas window.

You would now set up rules to identify each Detail, and set all of the details you do NOT want 
to print (left click) Properties, Suppress output.

Rules

You need to define one or more rules on your header, footer and data areas so the Repaginator 
can identify that text as that particular type.

Using the Header rule as an example, you require a rule to distinguish the header as the 
FIRST header for this document. You do not want your header area rule to succeed for every 
header instance, only the first. This means looking for "Page: 1" or a change in the document 
number. Ensure that the rule testing for "Page: 1" does not also succeed for "Page: 10", Page: 
11" and so on, as it WOULD for the example below where the page is left-aligned. In this case, 
use a "Change" value such as the Order No. Value.

To create a rule:

• Select the area you wish to create the rule on.

• Click the Insert match field tool  button on the toolbar, or go to the Insert 
menu, select
• Rule (match) - creates rules with default evaluation rule Equal to.
• Rule (change) - creates rules with default evaluation rule Change.
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• Highlight the text you wish to use for this rule. The rule is displayed in yellow 
and listed in the Areas window under the selected area.

• Select the rule and choose Properties from the Edit menu or click the Proper-

ties tool  button on the toolbar.

• In the Rule dialog box, you can change the evaluation Rule from the dropdown 
list.
• In the Value text box, enter the text the rule should match.
• To ignore the case of the text, tick the Ignore case checkbox.
• By default, the Repaginator looks for an exact string (including spaces and 

capitals). As a result, if the highlighted area for the rule is bigger than the text 
in the Value text box the rule will not succeed.

• To trim the size of the highlighted area during run-time (i.e. to look for the 
text in the Value text box somewhere within the highlighted area), tick the 
Trim checkbox.

• Click OK to save the changes to your rule.
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Properties

Once you have finished creating the areas in the entry, you can modify the entry and area 
properties.

Entry Properties

To modify the properties of the selected entry:

• Select the entry in the Areas window and click the Properties tool  button on 
the toolbar, or choose Entry from the Edit menu.

• The Entry dialog box opens.

• Change the Name of the entry which should represent that being processed.

• To insert text at the beginning of each document, enter the string in the Prepend 
with text box.

• To insert text at the end of each document, enter the string in the Append with 
text box. This is used to insert ##NEWDOC# which resets the page number for 
multiple documents from one file. The next (Form Feed) option is not required 
after a ##NEWDOC# command. To insert another document behind this one 
use these commands (typically used to insert a one-page terms and conditions 
document behind an invoice or PO):
• ##F#<form-name># where form-name is the name of the required form
• 0 (record mode) or just some data such as "base page" (print line mode)
• ##NEWDOC#

• To insert a form feed at the end of each document, tick the Form feed at the end 
checkbox.

• Click OK to save the changes.
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Area Properties

Once the areas have been defined, you can modify their properties, including height and rules.

In the data area(s), you also have the option to suppress the output. This is the normal 
approach to repagination. Suppress all that you do NOT want, leaving all of the remaining 
non-blank lines as the "keepers".

To modify the properties of the selected area:

• Select the area to modify in the Areas window and click the Properties tool  
button on the toolbar or choose Properties from the Edit menu.

• The Area dialog opens.

• Enter the new Height (number of lines).

• Select the properties of the rules defined on the selected area:
• All must succeed - As stated.
• Any can succeed - At least one of the rules defined on the selected must suc-

ceed to identify this area.

• Suppress output option applies only to data areas. To suppress the output of the 
data area tick the Suppress output checkbox. The data area icon in the Areas 
window changes to show it will be suppressed in the output.

• Click OK to save the changes.

Evaluation Order of Entries

It is most unusual to have more than one entry in a Repaginator file, however it has been 
allowed for. If your repaginator file contains more than one entry, you can modify the order in 
which those entries are tested. Entries with the most precise rules on the header should be 
placed at the top of the list.

To modify the order of entries:

• Select Order of entries from the Edit menu. The Evaluation order dialog box 
opens.

• Select an entry and click an ordering button to move the entry either up or down 
in the Order list.
• Highest - move the entry to the top of the list.
• Up - move the entry up one place in the list.
• Down - move the entry down one place in the list.
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• Lowest - move the entry to the bottom of the list.

• Click OK to save the changes.

Evaluation Order of Areas

If your repaginator file contains more than one area, or if your entry includes a footer and a 
data area, you can modify the order in which the areas are tested. Areas with unique rules 
should be placed at the top of the list.

To modify the order of areas:

• Select Order of areas from the Edit menu. The Evaluation order dialog box 
opens.

• Select an area and click an ordering button to move the area either up or down 
in the Order list.
• Highest - move the area to the top of the list.
• Up - move the area up one place in the list.
• Down - move the area down one place in the list.
• Lowest - move the area to the bottom of the list.
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• Click OK to save the changes.

Delete an Entry, Area or Rule

Deleting an entry will erase all the areas and rules under the entry, and cannot be undone.

To delete an entry:

• Select the entry you wish to delete.

• Select Delete from the Edit menu.

To delete an area or rule:

• Select the area or rule you wish to delete on either Areas Window or Mapping 
Window.

• Select Delete from the Edit menu, or the Delete tool  button on the toolbar.

Tools

Tools - Options

You can customize the colors of your areas and rules in the Options, as well as modify other 
options, to help you in the design and maintenance of your Repagination rules.

To configure the Repaginator options:

• Select Options from the Tools menu.
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• In the Options dialog box (recommended to tick both):
• Check the Apply underlying text after move / resize box to change the value 

of the underlying string in the print stream as you move or resize the rule.
• Check the Apply underlying text after create box to automatically populate 

the Value checkbox of your match rules as you create each match rule on an 
area.

• To change the color of an area or rule, select the area or rule you wish to 
change and click Change.

• The Color dialog box will be displayed. Select a new color from Basic 
colors, Custom colors, or Color matrix and click OK.

• Click the OK button to save your Repaginator options.

Tools - Test

When you have finished creating your entries, areas and rules, you can then test your 
repagination rules with the sample data file. You can return to FTDesign to continue 
designing your form with that repaginated output, or if the output is useful, can save the 
repaginated data file.

To test your rules and save the output from your test:

• Select Test from the Tools menu.

• The Repagination done window will be displayed containing the output from 
the repagination process according to the rules you have created. You will see 
your sample data has been reformatted, where:
• Header appears at the top and only once for each document.
• Footer appears directly under the header and only once for each document.
• Data areas are printed continuously without header or footer information 

separating them. Ensure ALL required data areas appear in the output, and 
NO superfluous lines appear.

• Click Save to save the output from the repagination process to a location on 
your system.
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• Click Close to close the Repagination done window and return to the FormTrap 
Repaginator.

Tools - Font

The Repaginator provides the option to change the display font for the input data file and the 
repaginated output. You MUST use a mono-spaced font, such as Courier New or LtrGothic.

To change the font in Repaginator:

• Choose Font from the Tools menu.

• In the Font dialog box,
• Font - select a monospaced font type.
• Font Style - font should be Regular or Bold.
• Size - select the size of the font. 10 or 12 point if preferable for most data 

files.
• Effects - do not Underline, remove by unchecking the Underline box.
• Color - select the color of the text.
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• Script - determines the writing system of the print stream in the Repaginator 
window. Western for English and most Roman fonts.

Running Repaginator from a Command Line
The Repaginator can be run as an input filter in the Spooler. Files where this is required are 
where there are two header areas, one for the total in the "running" area with detail lines, with 
remaining details in a report footer. The independent runs shifts one of the two header areas, 
with the other done in a linked repagination with the document.

The parameters for Repaginator are as below.

When running ftrpg from command line you should provide full paths. However if you are 
running ftrpg as a filter in FTSpooler V7 you can use the two special environment variables:

%fthome% - location of the home directory.

%ftinst% - location of the installation directory.
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The command line in this case would look like this:

“%ftinst%ftrpg.exe” –r”%fthome%\Repagination 
Rules\payment_initial.rpg” –i”%1” –o”%2”

Or in case when standard handles are used just:

“%ftinst%ftrpg.exe” –r”%fthome%\Repagination 
Rules\payment_initial.rpg”

This form is preferable because it allows FTSpooler to capture error mes-
sages and store them in logs. 

The optional –u parameter is used only on UNIX platforms when one or more file names 
contain non-ascii characters. In this case the command line itself should be UTF-8 (Unicode) 
encoded.
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FTSplitDef

The main purpose of FTSplit is to provide and implement rules for identifying data as it is 
received by FTSpooler. Once identified, data can be associated with a specific form or may be 
redirected to another queue for further processing, typically to be formatted using a different 
form. Such a need is common in two situations:

• where FormTrap is being used to process a large number of varied documents, 
which would otherwise require the creation of multiple FTSpooler queues; and

• where the file needs splitting into individual documents that require individual 
delivery (email or fax).

Splitting involves two components: FTSplitDef is the design environment that allows you to 
create rules for identifying and splitting batch runs; and FTSplit is the run time component 
used by the FormTrap Spooler. FTSplit allows you to identify data, split that data into 
separate documents according to your user-defined rules as well as removing unwanted pages 
of data such as summary details from the file.

FTSplit

FTSplit operates according to three sets of rules. For each type of data file you need to define:

• Identification rules - which identify the Entire File as one type of document.

• Unwanted page rules (optional) - which identify pages in the data stream that 
you do not want to process.

• Split rules (optional) - which identify information that is used to split the data 
file into individual documents (e.g. change in document number or page one).

When FTSplit receives a file, it performs the following functions:

• FTSplit analyses the data file to determine the type of document it is working 
with. This is done for the first three pages only, if the first of multiple entries 
does not succeed it looks at the second and so on.

• If the identified document has any unwanted page rules, FTSplit removes all 
pages from the data that match these rules before continuing.

• If the document type has rules for splitting, then FTSplit begins writing data to 
file until the first split rule succeeds. The file is then closed and FTSplit begins 
writing a new file until the split rule again succeeds. It does this until all docu-
ments in a batch run have been re-written to separate files according to the rules 
for splitting.

Note: Trying to split a SINGLE INPUT FILE into two or more alternate outputs 
CANNOT BE DONE. Each file is recognized ONCE ONLY, against ONE 
ONLY of the entries.

See the example on page 190 for emailing (or faxing) individual documents.

CHAPTER 9 
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FTSplitDef

Using FTSplitDef, you load a sample data file and create the rules to identify the data, remove 
unwanted pages and split the data file into individual documents. This information is saved 
into a rule file for use with FTSplit.

• Entries Window - contains a list of the defined entries.

• Mapping Window - displays the sample data file, onto which you can map the 
rules.

• Rules Window - displays the rules you have created for the selected entry.

Loading a Data File
Before starting on the rule file, a sample data file is loaded as a test case. The sample data 
must contain multiple pages or multiple documents as it is the variation across input pages 
that identifies the rules.
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To load the sample data file:

• Select Load Data File from the File menu.

• Select the appropriate test data file in the Open dialog box.

• Ensure Ascii / Unicode conversion is Auto.

• Click the Open button.

The test data file appears in the main window of your FTSplitDef screen.

If you see an empty page, press  (the first page may be just a carriage return). You will need 

to identify an "empty" page as "Unwanted page" .
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If you are splitting a Records Mode file, press Entry, Properties and adjust Maximum 
lines per page to 1 (one).

If the second page (press ) is not at the same distance from the top of the screen, then you 

have an unformatted file with no carriage returns in it. Press Entry, Properties and adjust 

Maximum lines per page to 60 and recheck using . Adjust Maximum lines per 

page until pages line up using  and .

Entry

Creating a New Entry

A new entry must be created for each different type of document that will be recognized. For 
each entry, the identification, unwanted page and split rules can then be configured.

Entries and rules are created differently for Records mode data/forms, see example here.

To create a new entry:

• Select New from the Entry menu or click the Add new entry button.

• The Entry dialog opens. In the Entry Name text box type in the name of the 
entry. The entry should have a meaningful name, usually the document type.

• Maximum number of rows per page defaults to 80 - in excess of most pages 
that are terminated by a Carriage Return.
• If the input file is Records Mode, set this to 1 (one).
• If the file comes from Unix Systems it may have a carriage return at the start 

(effectively an empty page) which will show here. Press  to see the first 
page. Likewise there may be no Carriage Return at the end of the page. Try 

setting Maximum number of rows per page to 60 and press  to see if the 
next page is at the same position on the page. Adjust Maximum number of 

rows per page until all pages are at the same position after  and .

• Click on the OK button.

The new entry appears in the bottom left hand corner of your FTSplitDef screen. You can now 
load a sample data file and start adding rules in.

Deleting an Entry

Deleting an entry erases all the rules under the entry, and cannot be undone.
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To delete an entry:

• Select the entry you wish to delete.

• Select Delete from the Entry menu.

Loading an Entry

To load an entry:

• Select Load from the Entry menu.

• The Load Entry dialog box opens.

• Choose the entry to be loaded, and click the OK button.

• All the rules of the selected entry are loaded.

Editing the Entry Properties

If the application generating the data file does not automatically insert form feed codes, but 
pads out the rest of the page with blank lines, set the maximum number of rows a page 
contains and FTSplit will paginate the data file accordingly.
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To change these settings:

• Select Properties from the Entry menu.

• Modify the Maximum number of rows per page if required.

• Click the OK button to accept the changes.

To confirm that you have set the correct page size, use the arrow keys to progress through the 
pages. The data should be in the same location on each page.

Evaluation Order

To process more than one type of document, you must create an entry for each type of 
document in your rule file, and you may change the document Evaluation Order.

To set the Evaluation Order:

• Select Evaluation Order from the Entry menu.

• Move those entries with more specific identification rules to the top using the 
up arrow button.

• Click on OK to accept the changes.

For example you may have an entry for Invoice and a separate entry for Invoice Reprint. The 
rules for these entries will be very similar with both entries using the heading INVOICE as an 
identification rule. However, the Invoice Reprint entry will require an additional rule which 
will identify the REPRINT string. The Invoice Reprint entry will need to be evaluated before 
Invoice Entry as it has less ambiguous identification rules. 
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Creating Rules
Once an entry is created, and there is data file to work with, the rules used to identify and split 
the data file are created. Some important points to note:

•  A rule consists of a particular area on the page and a text string.

• The area for a rule can be of any size and FTSplit will search the entire area for 
the text.

• Each entry MUST have at least ONE identification rule.

Creating Identification Rules

The identification rules in each entry are the first to be tested by FTSplit when it receives a 
data file. For each entry in the rule file, FTSplit evaluates the identification rules and if the 
identification rule is positive, FTSplit selects that entry and uses its rules. Each entry MUST 
contain at least ONE identification rule.

To create an Identification rule:

• Select the Identification rule button .

• Highlight the text that will be used to identify the document.

• The type of rule, its location and the text used to evaluate the rule is then added 
to the rules window.

A good place to find identification text is in the heading of each document. In the above 
example the heading P U R C H A S E    O R D E R has been used.

You can create as many identification rules as are needed to identify a document, and then 
choose whether FTSplit will match either all the identification rules, or at least one, before 
identifying a document. It is important to note that the identification rule is only ever applied 
to the first two pages of the data file. All pages following the second page are assumed to be of 
the same type of document. This has implications if:

• The data used for the actual identification appears later in the data; or

• Not all of the data file is of the same document type.
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To resolve either of these situations, it may be necessary to produce multiple rule files and use 
the queue redirection facilities in FTSpooler to correctly split the entire data file 
appropriately. Visit www.formtrap.com for more information.

Comparison Rules

A number of comparison options have been defined to assist in the identification of 
documents. The default comparison rule is Equal to. This means FTSplit will compare the 
data in the field on each page to the value or string specified in the rule file. The following 
comparison options are available:

To modify a comparison rule:

• Click on the Select tool button .

• Double click on the appropriate rule.

• The Rule Properties dialog opens. In the Comparison rule drop down menu, 
select the relevant option.

• The new comparison rule will appear in the rules window.

Comparison Rule Description

Equal to Field must be equal to the specified text string or value.

Not equal to Field must not be equal to the specified text string or 
value.

Greater than Field must be greater than a specified value.

Greater or equal to Field must be greater than or equal to a specified value.

Less than Field must be less than a specified value.

Less or equal to Field must be less than or equal to a specified value.

Empty Area must be blank

Not empty Area must not be blank
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Comparison Logic

The comparison made is shorter length of the string itself (in Rule Properties, Value) or 
the field (in Rule Properties, Length). Where the field cover multiple rows or the Length 
is greater, Splitter compares all available positions for the Value. When the Length is 
shortened, the Value is shortened to comply. Where the creation of the field includes leading 
blanks, these are NOT included into Value.

Creating Unwanted Pages Rules

If the data file contains pages which you do not want to print, you can create unwanted pages 
rules which will filter these pages out of the data file. These "unwanted pages" may include 
batch job summary pages or network banners. Like identification rules, unwanted pages rules 
look for specific text at a specific location. If the rule evaluates as positive, the entire page will 
be discarded.

To create an unwanted pages rule:

• Select the Unwanted pages rule button .

• Highlight the text that you want to evaluate.

• The type of rule, its location and the text used to evaluate the rule is then added 
to the rules window.

• The words BATCH RUN SUMMARY are used in the example below to iden-
tify the pages that will not print.

Creating Split Rules

Once FTSplit has used the identification rules to determine which entry in the rule file to use, 
it uses the split and unwanted page rules in that entry to split the batch run into individual 
documents and remove any unwanted pages from the data file.

Like identification rules, split rules look for a text string in a particular location on the page. 
For greater flexibility split rules evaluate the text in two different ways.

You can configure FTSplit to check if the string MATCHES a specific value or to check if a 
string has CHANGED value. When the split rule is evaluated as positive, FTSplit determines 
that page to be the first page of a new document.
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To create a split rule:

• Select the Split rule button .

• Highlight the text that you want FTSplit to evaluate.

• The type of rule, its location and the text used to evaluate the rule is then added 
to the rules window.

• A Split on Change rule has been used in the example below. Here FTSplit will 
examine the customer number from page to page and split documents when a 
different customer number appears.

For more information on Evaluation Rules page 181.

Editing Rule Properties

Once you have created a rule, you can change its properties either by moving the rule location 
with the mouse or by manually specifying its new location and text.

To move the rule location using the mouse:

• Click on the Select tool button .

• Click on the rule to select it.

• Drag the rule to a new location or resize it using the white handles.

To manually specify the new location:

• Click on the Select tool button .
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• Double click on the rule or select Properties from the Rule menu.

• Here you can specify the rule location and the text used to evaluate the rule, 
regardless of what text appears at the rule location on the current page.

Within Area Matching

You can match "within an area" if you are not certain where the target is going to occur. This 
normally happens with literals in comment lines or when the originating program is 
inconsistent.

To match "within an area":

• Put in an exact match - normally "Equal to" for the required character (s), "X" in 
the example.
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• Use the pointer to expand the area looked at. If the character(s) occur anywhere 
in this area, a "success" is recorded.

Evaluation Rules

After the identification, unwanted and split rules have been defined it is important to 
configure the rule evaluation for each entry in the rule file. The evaluation method of each 
type of rule (identification, unwanted and split) can be set so that either all rules must match 
or any rule must match.

In some instances you may need to create a combination of rules to successfully split/identify 
your data. For instance, you would need more than one evaluation rule to determine the 
difference between an invoice and a reprinted invoice. FTSplitDef will allow you to define how 
multiple rules are handled by the FTSplit in two ways:

• All must match to qualify - as stated.
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• Any one matched to qualify - one or more rules must match for success.

Split rules can be further controlled. Split rules can be set to:

• Split on match - meaning that the rule must exactly match to succeed. For 
example, a split rule using the page number would split the document when the 
page number was equal to, or “matched” the value 1. Use leading and trailing 
spaces to avoid splitting on page numbers 10, 11, 12, 100, 101, 102 etc.

• Split on change - meaning that if the text in the rule changes the rule succeeds. 
For instance, a split rule on a change in the customer number splits when a new 
customer number was present.

To configure the rule evaluation for each entry:

• Select Evaluation Rules from the Rules menu.

• For each rule type, set whether all rules or at least one rule must be satisfied 
before the action occurs.

• On the Split tab, select the correct Split on option.

• Click on the OK button.
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Options

Font Options

The attributes of the font used for the sample data file is set in the Font Options.

• Choose Font from the Options menu. Only fixed width fonts are shown.

• In the Font dialog box,
• Font - select the font type. Courier New is ideal.
• Font Style - select Regular (Bold, Italic and Bold Italic are unsuitable).
• Size - select the size of the font.
• Effects - leave as not Underlined.
• Color - select the color of the text.
• Script - select Western from FTDesign version 6.4 forward (Unicode).

Preferences

To configure the Preferences of FTSplitDef:

• Choose Preferences from the Options menu.

• In the Preferences dialog box,
• Check the Show dialog after rule creation box enables the Rule Properties 

window to pop up at the time of creating the rule.
• Check the Apply underlying text after move/ resize box to change the value 

of the underlying string in the data file as you move or resize the rule.
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• Rule Colors - define the colors for Identification, Unwanted pages, and 
Split rules respectively.

Split Options

The default folders that FTSplitDef locates the input and output files are specified in Split 
Options.

To configure the Split options of FTSplitDef:

• Choose Splitting from the Options menu.

• In the Split options dialog box, click the browse "..." button to select the default 
locations for input and output files.
• Look in - the default location of raw data files.
• Split files into - the default location of output files.

Splitt ing
Before going to production, the split rule file needs to be tested. The locations of splitting 
input and output files are defined in  Split Options.

To test the rule file:

• Select Split from the File menu.

• Select a test data file.

• Click the Open button.
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• The Split Result dialog opens.

• Click the OK button.

To ensure the rules are identifying and separating the documents correctly, browse the 
documents with a text editor. The first file created by FTSplit contains all the unwanted pages. 
This file is always created, even if there is no unwanted page data.

Examples
Here are two examples showing the split operation in both Print Line and Records mode.

FTSplitDef and Print Line mode

In the example below, the rule file is configured to distinguish between purchase order and 
invoice data, and to split on a change to the customer numbers.

To configure a rule file:

• Define the Entry for purchase order and set the maximum number of rows per 
page of your sample data.
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• Load a sample purchase order data.

• Define the Identification rule, Equal to P U R C H A S E    O R D E R in the 
example below.

• Define the Split rule by highlighting the customer number 56789.
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• Select Evaluation Rules from the Rules menu. On the Split tab, choose Split on 
Change.

• Define the Entry for invoice and set the maximum number of rows per page of 
your sample data.

• Load the sample invoice data.
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• Define the Identification rule, Equal to Invoice No in the example below.

• Define the Split rule by highlighting the customer number 333241.

• Select Evaluation Rules from the Rules menu. On the Split tab, choose Split on 
Change.

• Test the splitting results by clicking the Split option from the File menu.

FTSplitDef and Records mode

Entries and rules are created differently for Records mode data. The example below explains 
how to handle Records mode data.

To configure a rule file for records mode data:
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Define each Entry as ONE line (i.e. one record long).

Create your identification rule in record 0: Base page. The base page record should contain a 
field that can be used to uniquely identify the data.

Define the split rule (if required) as the 0: Base page character. The identifier 0: Base Page 
record indicates the beginning of a new document.
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The Unwanted Page rule only removes specific records from the data, not whole pages and is 
generally not required in Records mode.

Splitt ing Files to Email (or Fax) Documents
To deliver according to conditions in a document you MUST be processing just the ONE 
document. This means you'll need to split incoming files into individual documents BEFORE 
testing for the delivery condition. The Splitter treats entire FILES the same way, if you are 
attempting to identify DOCUMENTS in a multi-document file you'll get the ENTIRE FILE as 
the first case recognized. This is the correct procedure for emailing individual documents:

Queue 1

Split the file into individual documents:

Deliver ALL individual documents to Queue 2 "process" queue.

Queue 2 - Process Queue

In the Process queue, apply the "EMAIL" test and allow all other documents to go to "Print".
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